SW3: Ixora Board

Hello,

I’m trying to program the switch SW3 on the carrier ixora board / imx8qm v1.1B (BSP 3.03b) . The switch is connected by default to pin 186 (which is in turn connected to GPIO5.IO26 ) since the resistors R91 is assembled and the R90 not.
I muxed the pin to the gpio function and disabled the device which uses the pin

	pinctrl_factory_reset: factoryreset {
		fsl,pins = <
			SC_P_USDHC2_DATA0_LSIO_GPIO5_IO26	0x06000020
		>;
	};
&usdhc3
{
	status = "disabled";
};

By setting the GPIO5.IO26 as input or event-based input in the code, and clicking on the switch, the value of the GPIO doesnt change. I also tried to read the value of GPIO5.IO26 with the gpiod tool but same result:
gpioget 5 26

Am I missing something to be configured?
Thanks in advance.

Best regards,
Majd

Hi @majd.m !

Could you please check if you are really using Apalis IMX8 and BSP3?

There is no support for Apalis IMX8 on BSP3. Although there is the MACHINE for this module on BSP3, it is not supported.

You must use BSP5 for Apalis IMX8.

Also, which Ixora version are you using?

Best regards,