Splash Screen with U-Boot at runtime

I’working with Boot2Qt 5.14.2 sw stack loaded on Apalis iMX6 1 Gb with Toradex Easy Installer via an USB key where I extracted the tezi.tar file provided by QT. My development environment is Windows 10 + QT for Device Creation.
I can edit the uEnv.txt file on USB key to configure U-Boot before to install the OS on the target (with this method I have succesfully set the resolution of the target TFT screen). I can build an application from my IDE under Windows and upload it to the target.
It is possible to add other commands to have my custom logo as splashscreen at boot?

Obviously I have already read the Splash Screen on U-Boot | Toradex Developer Center page.
Created a simple BMP file on GIMP (Ms Windows) named logo.bmp, uploaded to the rootfs of the target under /boot, and tried to load at U-Boot shell with ‘bmp display /boot/logo.bmp’. The result is: there is not target file in /boot. But… at U-Boot time the rootfs is already mounted???

I dont’ want to embed the image in the U-Boot rebuilding it and I if not necessary I don’t want to work on Linux for now.

Thanks in advance,
Pietro

Putting a bitmap up takes two steps:

  1. load the image into memory using fatload. Make sure device:partition is correct.
    (e.g. “fatload mmc 0:1 $loadaddr logo.bmp”)

  2. use bmp display with the address of the image in RAM. You can’t give it a filename. (“bmp display $loadaddr 0 0”)

Hi, thanks for answer,

I tried:
Added “fatload mmc 0:1 $loadaddr logo.bmp” and “bmp display $loadaddr 0 0” to my uEnv.txt file.
Flashed the OS. It boots and the resolution is right. 1280x800 as per vidargs parameters: video=mxcfb0:dev=hdmi,1280x800M@60

Created a ‘logo.bmp’ file 1280x800 8bit with GIMP and uploaded with Bitvise SFTP to a temporary folder on the EXT4 fs.
From a terminal, with ‘fdisk -l’ seen that the FAT partition is /dev/mmcblk2p1. Mounted in /mnt/fat.
Ls show me the same files the ones in the EXT4 /boot/ folder plus one named ‘apalis_imx6’ and one ‘boot.scr’.
Cp the logo.bmp from the temporary folder to /mnt/fat. Trying to unmount the output says it si busy.
Tried to unmount other times without success, then shutdown. Reboot and after remounting the /dev/mmcblk2p1 the logo.bmp file was there with it’s size.

Anyway at boot the image was not shown.
If I interrupt U-Boot can I show the image in some way?

‘vidargs’ are parameters passed to the Linux kernel. They won’t help you here.

Yes, if you interrupt u-boot you can enter these commands by hand and see what isn’t working. Another useful command is fatls (e.g. “fatls mmc 0:1”) to list the files in a FAT32 partition on your eMMC or SD.

Some steps forward:
as for previous post created the ‘logo.bmp’ file.Put it in FAT partition
Re-boot the device and entered U-boot prompt
As for instructions on Toradex website:

mmc dev 0

mmc rescan

load mmc 0 ${loadaddr} logo.bmp

The output says: correctly loaded xxxxx bytes in memory

Then:
bmp display ${loadaddr}

The output says:
unsupported panel CLAA-WVGA

I tried with other bmp 8bit of 600x400 or another downloaded from the internet as example, but everytime the same message.
Any suggestion?