Spidev not showing up under /dev or /sys/bus/spi/devices

I am using a Colibri imx6ULL COM with an iris-v2 carrier board. I enabled spidev and spi node in the device tree as well.

dtb output:

spi@2008000 {
					#address-cells = <0x1>;
					#size-cells = <0x0>;
					compatible = "fsl,imx6ul-ecspi", "fsl,imx51-ecspi";
					reg = <0x2008000 0x4000>;
					interrupts = <0x0 0x1f 0x4>;
					clocks = <0x1 0x8b 0x1 0x8b>;
					clock-names = "ipg", "per";
					dmas = <0xd 0x3 0x7 0x1 0xd 0x4 0x7 0x2>;
					dma-names = "rx", "tx";
					status = "okay";
					cs-gpios = <0xe 0x1a 0x0>;
					pinctrl-names = "default";
					pinctrl-0 = <0xf 0x10>;
					phandle = <0x58>;

					spidev@0 {
						compatible = "toradex,evalspi";
						reg = <0x0>;
						spi-max-frequency = <0x15ef3c0>;
						status = "okay";
						phandle = <0x59>;
					};
				};

I also made sure that my device tree has been loaded properly into the board. I even checked the kernel configs to make sure spidev and everything related to spi is enabled.

After a while I found out that none of the .ko modules are loaded into the board. I am not sure if this is the reason for spidev not showing up. If yes, is there a workaround for this case?

Hi @SurriyaLuavan,

In order to help you with this issue, could you please share more information about your setup with us? Specifically:

  • Which Colibri iMX6ULL version you are using? With or without Wi-Fi?
  • Which OS are you using? TorizonCore or BSP? Which version?
  • Did you update your kernel in some way? If so, how?

Best regards,
André

Hi, @andre_m.tx

I was able to figure out what the problem was! Thank you