SPI causing output pin to appear as "busy." How to disable SPI for that pin in IMX6?

Build Configuration:
BB_VERSION           = "1.40.0"
BUILD_SYS            = "x86_64-linux"
NATIVELSBSTRING      = "universal"
TARGET_SYS           = "arm-tdx-linux-gnueabi"
MACHINE              = "colibri-imx6"
DISTRO               = "tdx-x11"
DISTRO_VERSION       = "2.6-snapshot-20210127" 

Once I load my build onto the board, I call can call “gpioinfo” or “gpioget 4 2” to see that “spi_imx” is being used and will report as “Device or resource busy”

To my understanding, I need to go into the DTS files and set status = “disabled” in order to disable the SPI. However, doing this seems to have no impact. In my tmp/…/dts/ directory, I have gone through and adjusted the imx6dl-colibri-* files. In the spi4 blocks, the status has been changed to disabled. Am I supposed to do more? Am I not targeting the correct one?

I am a bit stuck on this and any insight is appreciated.

Edit to add more info:
All the methods of trying to toggle/change GPIO done in Linux user space and does NOT accomplish what I’m trying to do. Therefore, to my understanding, I should be able to manually toggle this IO via uBoot/Device Tree. However, I haven’t seen any of these changes take place in user-space.
All GPIO are direct-wired, without any IO expanders in place. So it seems that SPI might not be the primary issue here (or one at all?).
However, the pins have multiple options, however, the one I’m seeing an issue with also could be a chip select for an SPI line.

So with this, it is just a guess that SPI interface is on and is what is causing the pin to be busy.

Yes you need to change .dts or .dti file to disable SPI than compile a new Device Tree to .dtb file and replace an old one. Please check this articles:

So if the DTS was adjusted to show ‘status = “disabled”’ then I can assume it’s something else and not an SPI issue? I figured with me seeing no noticeable differences in the build, that I was not adjusting the device tree correctly.

Yes. But if you :

  • disabled proper node

  • Compiled source to .dtb correctly.

  • Properly replaced old .dtb with a newly compiled one.

Since you " have no impact. In my tmp/…/dts/ directory," something from above list was done incorrectly