Some questions regarding to setenv vidargs for VGA display

I’m using load from usb method to boot my easy installer and image.
I use “Apalis-iMX6_ToradexEasyInstaller_1.8-20181019” as my easy installer to install “Apalis-iMX6_Console-Image-Tezi_3.0b4.254”.
I was able to set the output of my image on display via VGA after i set the appropriate commands in uboot.
The problem i faced was when i try installing “Apalis-iMX6_Reference-Multimedia-Image-upstream-Tezi_5.3.0+build.10”. I was able to install it but monitor did not detect anything from my VGA output even after i repeat the same procedure as “Apalis-iMX6_Console-Image-Tezi_3.0b4.254”.

Hardware:
Apalis IMX6Q 1GB V1.1B
Apalis Evation Board V1.1A

Commands in Uboot:
setenv vidargs ‘video=mxcfb0:dev=vdac,1280x720M@60,if=RGB565 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M’
saveenv

Hi Raymond,

Starting BSP version 5.x not all display are enabled by default in Linux device tree, one should use appropriate device tree overlay to enable display.

Please have a look on below mentioned article explaining about device tree overlay.
https://developer.toradex.com/knowledge-base/device-tree-overlays-linux

Please feel free to write us if you have any queries.

Best Regards
Ritesh Kumar

Hi @ritesh.tx , thank you for the feedback. May I ask if this apply to 5.3.0 Easy installer as well?

Hi @Raymond,

Indeed this apply for Toradex easy installer 5.3.0, which is now the same base BSP as our other embedded Linux offerings.

Inside Toradex easy installer there will be overlays.txt which should work same way as in Linux Image.
Please check below link for detail information

https://developer1.toradex.com/knowledge-base/toradex-easy-installer-create-image?review=post&id=103192#Changing_the_default_device_tree_overlay

Best Regards
Ritesh Kumar

Hi @ritesh.tx , the method works for Tezi but not “Apalis-iMX6_ToradexEasyInstaller_5.3.0+build.3”.


After following the link to enable overlay for VGA display for the image, the display did not show anything.
I also got try to setenv in uboot method:
setenv vidargs ‘video=mxcfb0:dev=vdac,1280x720M@60,if=RGB565 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M’
saveenv

Hi @ritesh.tx ,
Thank you. It works after i remove others and left VGA only.
image

1 Like