[Solved] Issue with iMX8QXP Bring-up: No Host Port Communication


I’m having an issue with the bring-up of my iMX8QXP.

In summary:

• I’m writing the SD card image to a 16GB class 10 micro SD card

• I insert the SD card into the SD card slot on the Iris carrier board (with iMX8 module).

• I power on the device with 12v

• Everything powers on, current is being drawn (around 0.15A - 0.2A) but I’m not able to communicate with the device on the x13 connector using RS232 (115200 baud). I just get a blank terminal with no data.

When I swap out the iMX8 with a Colibri iMX6ULL or iMX7 everything works fine and I can communicate through my PC’s terminal. All else being same.

I’ve tried two different methods for writing the image to an SD card, both have the same issue.
First, I downloaded the image provided by the ‘Getting Started’ page on this forum. I CD’ed to the image directory, then I ran the following commands:

sudo umount /dev/sdc
bzcat fsl-image-validation-imx-colibri-imx8qxp-20181112152945.rootfs.sdcard.bz2 | sudo dd of=/dev/sdc bs=4M

After trying that method without any luck, I tried the ‘Build Apalis iMX8/Colibri iMX8X OpenEmbedded/Yocto Project Bring-up Image’ method.

repo init -u git://github.com/toradex/imx-manifest.git -b toradex-linux-rocko -m toradex-4.9.123
repo sync
MACHINE=colibri-imx8qxp DISTRO=fsl-imx-xwayland source fsl-setup-release.sh -b build
bitbake fsl-image-validation-imx
sudo umount /dev/sdc
cd tmp/deploy/images/colibri-imx8qxp
bzcat fsl-image-validation-imx-colibri-imx8qxp-20190205183859.rootfs.sdcard.bz2  | sudo dd of=/dev/sdc bs=4M

I’m under the impression that the UART A is being used at the x13 connector on the Iris and that UART A is backwards compatible with other Colibri modules.
If anyone has any ideas or insight as to what I need to do to establish communication, I would greatly appreciate that. I’m really excited to get to work with the iMX8QXP.


Yes, you should be able to communicate over UART A.
If you reconnect that SD after sync , can you see two partitions with files on them?

Yes, when I re-insert the SD card I see two partitions.

One partition labeled, ‘2.4 GB Volume’ with OS related files (bin, boot, dev, etc, home, etc.)

The other partition labeled ‘Boot colibr’ with the folder, ‘System Volume Information’ and two files ‘fsl-imx8qxp-colibri-eval-v3.dtb’ and ‘Image’.

And that same UART A and SD card work fine on your Iris if used with a different Colibri module?

I tested UART A with my iMX6ULL yesterday and it worked fine.

I’ve tested the SD card on the Iris board several months ago and it worked fine but since it’s been a while, I will re-validate to make sure it’s still working and report back the results.

Also, I have another iMX8 that I can test to cross-verify but I don’t have access to it today so that will have to wait until next week.

I managed to establish communication with the iMX8!

I was using RS232 on the x13 connector with a proper RS232 adapter (which worked fine on my iMX6ULL) without any luck.

I decided to try to communicate with the board via TTL directly on UART A (pin 27 and 28) on the x16 header and it worked.

Thanks for your help and prompt replies!

Perfect that it works. Thanks for the feedback.