Serial line disturbances in U-Boot

Hi,

I’m experiencing a lot of disturbances on serial line in U-Boot. This can be seen in the log below, where I pressed the dot (.) key for longer time on U-Boot prompt. As the board echoes back the received characters, it can be seen that the received character is often different from ..

The disturbances can be seen on an oscilloscope. Rectangular wave is superposed on the RS232 TX signal. Unfortunately, I don’t have the screenshot right know, because I measured that in the past. From what I recall, the amplitude of the superposed signal was about 5V and the frequency was (if I remember correctly) 500 kHz.

This happens only in U-Boot. Once Linux boots up, its serial console on the same port works flawlessly and the superposed signal disappears.

I have tried different USB-to-RS232 converters. The below log is obtained with PL2303-based converter. When using FTDI-based converters, corruption is visible in almost every echoed character.

If the Linux serial console doesn’t work, I’d say that this is caused by some electrical problem on our side, but given that it appears only in U-Boot, I’d say the problem is somewhere else. Any idea where?

U-Boot 2020.04-5.1.0+git.0a26a04408ca (Jan 01 1970 - 00:00:00 +0000)

CPU:   NXP i.MX8QM RevB A53 at 1200 MHz

DRAM:  4 GiB
MMC:   FSL_SDHC: 0, FSL_SDHC: 1, FSL_SDHC: 2
Loading Environment from MMC... OK
In:    serial
Out:   serial
Err:   serial
Model: Toradex Apalis iMX8 QuadMax 4GB Wi-Fi / BT IT V1.1B, Serial# 06738445

 BuildInfo: 
  - SCFW 732e719a, SECO-FW 376e3c15, IMX-MKIMAGE 6745ccdc, ATF 
  - U-Boot 2020.04-5.1.0+git.0a26a04408ca 

switch to partitions #0, OK
mmc0(part 0) is current device
flash target is MMC:0
Net:   eth0: ethernet@5b040000
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot:  0 
Apalis iMX8 # ............>.�.........�/.../......................./..............�..........�.../..././../

Hi @wentasah,

Thank you for using the Toradex Community.

Would it be possible for you to share a diagram on how your setup is connected together? Is there a Hub in between?

Is this only happening on a single device?

Best Regards
Kevin

Thanks for the reply!

The setup is pretty straightforward. I use a USB hub, but the problem appears also without the hub, when connected directly to the laptop as in the diagram.

I have only one board so I cannot test it with a different one.

Hello wentasah,

can you check if this is happening with a different terminal program as well? like gtkterm?

Best regards,

Matthias

Yes, it happens in all terminal programs.

Different UART behavior at U_boot and Linux can be caused by different pin drive strength settings. However I’ve never seen such a UART behavior with default U_boot on a hundreds Ixora board literally.

Could you try to use different cable between X22 and your USB-to-RS232 converter?

Thanks for the help. I tried replacing everything except that cable and of course, the problem was there. After replacing that cable, it started to work. I however have no idea why serial console worked on Linux and not in U-Boot.

Hello wentasah,

thanks for the feedback.

Best regards,
Matthias

Different UART behavior at U_boot and Linux can be caused by difference in UART pin drive strength settings.