Serial console showing gibberish with Ixora V1.2 and Apalix IMX8

Hello everyone,

I am trying to connect to my apalis module and Ixora board using a serial connection, I am using the FTDI USB to serial cable C232HD-DDHSP-0 ( ) and connecting to the X22 connector on the Ixora board

I tried cross-connecting the DTR/RTS … etc , and also with just the RXD and TXD and turning off hardware flow control, but I keep getting gibberish. the following is my configuration :

The board works properly and starts the the portainer app, I installed the torizon core from the easy installer, I can connect to the board normally using the IP address

please advise

Please advice

Dear @AhmedMobarez,

Welcome to our community! Please feel free to roam around and ask any questions you may have related to Toradex Universe.

I had a quick look at the datasheet you sent us and compared it to the Ixora one (Ixora Carrier Board) could you please confirm that you’re connecting pins on X22 as follows? If you have a look here, it states which pins are needed to access each UART interface: UART (Linux) | Toradex Developer Center

Black 10 GND → 9 Ixora X22 GND
Blue 9 RI → 8 Ixora X22 RI
White 8 DCD → 1 Ixora X22 DCD
Purple 7 DSR → 2 Ixora X22 DSR
Gray 6 DTR → 7 Ixora X22 DTR
Brown 5 CTS → 6 Ixora X22 CTS
Green 4 RTS → 4 Ixora X22 RTS
Yellow 3 RXD → 3 Ixora X22 RXD
Orange 2 TXD → 5 Ixora X22 TXD

Also, are you sure that you’re trying to connect to the right port?

Finally, I suppose you’re on Windows right? Have you tried connecting using another software such as Putty? Serial Terminal Emulator | Toradex Developer Center

Best regards,

Thank you for your quick reply.

I have connected the cables in the configuration you mentioned and no change, check below:

I am connecting to the UART1 in the X22 connector as shown in the image above, this is according to the toradex quick start with the ixora board.

Please check below for the com port and putty connections, also tried teraterm and no changes:

Dear @AhmedMobarez, how are you?

The wires seem to be properly connected. Did you test it with another cable or another Carrier Board?

Best regards,

A new update,

I tested from another computer running linux 20.04 and minicom 2.7.1, still no luck

please let me know how to proceed, I will be able to test with another board next week


Hello @gclaudino.tx , Sorry for the late reply,

I have tried with another similar cable and also sparkfun FTDI basic breakout board by connecting only RX and TX, check here : SparkFun FTDI Basic Breakout - 3.3V - DEV-09873 - SparkFun Electronics

Same result

I will try to test with another board but I don’t have it on hand at the moment, could there be something wrong with the baudrate ? how do you recommend I debug this issue on the board ?


Dear @AhmedMobarez, the baud rate seems to be fine. I always use 115200 for it. Please test it with another board for us to check if this could be the case for an RMA.

Best regards,

Dead @gclaudino.tx ,

We have tested the serial connection with this adapter and everything works fine, not sure why the other one didn’t work, thank you for your support

1 Like

Dear @AhmedMobarez,

Thanks for the update. I’m glad it’s working now.