SATA multipler not working on Apalis iMX8

Hi Toradex,
We are using SATA multiplier(88SM9705) in our custom carrier board. This is working well with iMX6 and Hard disks are also mounted properly.

When we are connecting the iMX8 SOM on our custom carrier board then Hard disks are not detecting,
but If we connect single hard disk then it is working.

We have tried to reduce the SATA link speed from sata2(3Gbps) to sata1(1.5Gbps) by adding below line in u-boot.
setenv defargs $defargs libata.force=1.5Gbps
After changing to 1.5Gbps also it is not working.

Kernel version:
Linux apalis-imx8 5.4.77-5.1.0-devel+git.8fc7bd5da76f #1 SMP PREEMPT Mon Nov 30 08:44:04 UTC 2020 aarch64 aarch64 aarch64 GNU/Linux

Thanks & Regards,
Swamy.

Hi @narayanaswamym,

Can you please share more details on hardware version and software modification if any?

Also please share the dmesg log, if possible kindly share working (imx6) and non working(imx8) logs.

Earlier in below post you mentioned this is working with our latest release. Is that still valid if not is it possible to test with 5.4 or even say from our nightly build.

Additionally check below known issue

Best Regards
Ritesh Kumar

Hi Ritesh,
Kernel version :
Linux apalis-imx8 5.4.115-5.3.0-devel+git.64dbf17bb33e #1 SMP PREEMPT Thu May 27 21:52:13 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux

For latest BSP releases sometimes working and sometimes not. I have attached working and non-working dmesg files for i.MX8 and working dmesg files i.MX6.

Regards,
Narayana Swamy M

dmesg_imx8_sata_sometimes_working (42.4 KB)
dmesg_imx6_sata_working (57.8 KB)
dmesg_imx8_sata_not_working (36.1 KB)

hi @narayanaswamym ,

Thanks for sharing logs.

Since we do not have same hardware with us it’s difficult to reproduce issue at our end. Its seems like issue is related to below mentioned known issue.

As a workaround can you please try compiling the SATA driver as module and check if that solve your issue.

CONFIG_SATA_AHCI=m
CONFIG_AHCI_IMX=m

Update: With 5.4.0 release this is fixed. You may like to test same.

Best Regards
Ritesh Kumar

Hi @ritesh.tx ,

We have tried with latest monthly released BSP, but we are facing same issue.

root@apalis-imx8-06874983:~# uname -a
Linux apalis-imx8-06874983 5.4.129-5.4.0+git.cb88cc157bfb #1 SMP PREEMPT Wed Sep 29 18:17:21 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux

Please find the dmesg log file.
dmesg (41.8 KB)

Regards,
Narayana Swamy M

Hi @narayanaswamym

I could able to reproduce the issue at my end. Could you force the SATA link to 3 Gbps or 1.5 Gbps in the u-boot and try again. With this, Both the Hard drives are detecting and mounting properly. The connection is also stable. I tried with the latest Linux BSP v5.4 reference-multimedia-image.
setenv defargs $defargs libata.force=1.5Gbps