Running custom Linux kernel on Colibri t20 module with Iris V1.1A carrier board


I am planning to build a custom linux kernel for Colibri t20 (256MB V1.2A) module with Iris V1.1A carrier card for GSM module as suggested in the below post.

I have downloaded the linux-toradex git and built the linux kernel with default configurations, below are the steps i followed to build the kernel.

export ARCH=arm
export PATH=~/gcc-linaro/bin/:$PATH
export CROSS_COMPILE=arm-linux-gnueabihf-
make clean
make colibri_t20_defconfig
make -j3 uImage 2>&1 | tee build.log

After generating the uImage, I have executed the below commands from Ubuntu desktop for downloading the kernel putting module into a recovery mode:

cd ~/Colibri_T20_LinuxImageV2.3/colibri-t20_bin
cp ~/linux-toradex/arch/arm/boot/uImage ./uImage-custom
ln -fs uImage-custom uImage
cd ..
./ -k -r 256 -v V1_2

After removing the jumper 1 and trying to boot the module in normal I am getting the error and module got stuck some where(attached boot log file).

Actually I tried to load custom kernel but it didn’t worked then I trying with default configurations. I need help in building and loading the kernel. Is any thing that I am missing while building the kernel or could some one can share the kernel configuration file for building it.

Regards, text

Please note that for the BSP V2.3 you would need to either explicitly build resp. tag or if trying to build the top of the tegra branch which includes all the latest fixes and such you would need to revert the following commit due to fundamental changes in the MTD raw NAND layer et al.

Hi Marcel,

Could you please explain me in detail, because after reverting the changes you have suggested I am getting the build error.Attached screenshot.


Sorry, but I don’t look at any shady screen shots. Either post the full textual output of what exactly you are doing or we won’t be able to help you.

Concerning cross compilation of the Linux kernel please do adhere to the following article on our developer website! E.g. in your case you may just having missed to properly do a make colibri_t20_defconfig before attempting any compilation.

Hi Marcel,

Sorry for the miscommunication.

I am able to build the kernel with the changes you have suggested and it is working.