RTCsync with Colibri T30 on WEC7 V2.0Beta2

Hello,
with Colibri T30 IT and IRIS board we migrated from WEC7 image version 1.4 to v 2.0Beta2 and find out that RTCSync is not working. We tried our own wrapper RTC I2C which works well on WEC7 v1.4. But on image WEC7 2.0Beta2 is not working (in our SW there is no error from I2C interface init, lock or read/write functions). It seem that RTCSync only reads data from RTC chip on boot, but writing to the chip is not working. We tried to change the windows system time and call RTCSync manually - without succes. Our RTC wrapper also cannot write to RTC chip anything. Colud you please check this behavior. Thanks

Martin

We Tested this on a Iris 1.1A on Colibri T20 and T30 using our standard RTCSync. It worked without any issue.

Test procedure with enabled debug port:

  1. Boot device without Ethernet inserted. RTC reports “Invalid time on External RTC, please set a valid time
  2. Attach Ethernet and set correct time. Debug port reports "RTC Time set (03.11.2016 10:03:12)"
  3. Reboot device. Got “RTC Time restored (03.11.2016 10:03:54)” on the debug port.

Is there anything different at your side?

Thank you, we reflashed the image again to WEC7 v2.0Beta2 and tried your procedure, and it worked well. RTC time was saved and restored correctly. Even in win shell it is working. My apology, our flashing method from yesterday must somehow went wrong and corrupt something, because after reflashing and running your test, it seems to be ok.

Thank you very much

Martin