Rpmsg_Init access violation after upgrade to ToradexCELibraries 2.2

After upgrading ToradexCELibraries from v2.1 to v2.2 I found a strange behavior that I can’t explain.

First of all, Rpmsg_Demo sample works as expected and this made the investigation much more difficult, unfortunately.

If I build my custom application both in Debug and in Release, I copy it on the module and I run it using Autorun/Autocopy feature, everything is ok.

But if I try to debug the same application from VS2008, Rpmsg_Init() fails with message

Unhandled exception at 0x0018549c in MyApplication.exe: 0xC0000005: Access violation.

If I run from VS2008 the same application built in Release mode, it works.

Is it possible the library can have problems if the debugger is attached?

I don’t know if this helps, but my application creates two additional threads before calling Rpmsg_Init().

Rpmsg_Demo sample works when the debugger is attached.

Could you help me with this strange behavior?

Do you need some other information from my side?

@vix, we need to look at this a bit closer and will get back to you shortly.

Dear @vix,

Thank you for reporting the issue with details. This issue is related to this one: http://www.toradex.com/community/answers/24454/view.html. So could you please try that preliminary library release and let us know if it doesn’t help.

Thank you