Resource Manager Registry Settings dont work?


I tried to use the Resource Manager Registry Settings for the latest WEC7 image (2.1 beta 2) for the T30, to see if could get it to run with lower temp.

It seems that we on some on our production runs a bit to hot (Resulting in restarts!!!)

Before I updated I had the 2.0 released image.
After 5 min idle the CPU was 57 degree and the module 50 degree

I updated to the 2.1 and after 5 min the was CPU 86 degree and the module 70 degree

In the TaskManager I could se that the EMC clock was 400 MHz (In the 2.0 build it was 266 MHz)
Also is the CPU clock always 500 MHz ?
The EMC clock was 266 MHz with image 2.0

Added the registry keys for the resource manager has no effect. No lower EMC or CPU clock.
I know the the EMC clock can be lowered using the recovery mode, but that is impossible for produced units and units at costumer.


The CPU load is due to the Remote Display access.

And I seems that version 2.1 beta 2 is will run to hot when idling on the desk…
A heatsink seems mandatory when using the latest image!?

Hello @TJO

Heating issue

Yes, the 2.1b2 is running hotter due to higher RAM timings. We will have to implement Dynamic Freqeuncy Switching on the EMC before creating a 2.1 final image. This will probably be added in one of the next releases. We already introduced two features to reduce these kind of issues:

  • The CPUs can be switched off dynamically since 2.1b2. Details are documented here. This is disabled by default.
  • We introduced a thermal throttling as documented here. This feature is enabled by default.

Resource manager Registry Settings

I quickly tried some settings. For example setting DfsCpuHighCornerKHz = 50000 worked fine. Which key did you try with? It could be that you set a the max values which will never be reached due to thermal throttling?

Lower RAM Timings

If you want to flash an image with lower RAM timings you could also flash the image by using the latest Update Tool and either add the following section to the *cfg file


or run updatetool.exe /u default_533.bct if you only want to downgrade the RAM timings. This was previously only possible by NVFlash.


I have tried different setting in the Beta 2.1 and the EMC clock has a massive impact on the CPU temp.

Would it be possible to lower it even more? F.ex. t30_emc_clk=400000 ??
Is it possible to run an update with only the “[general] t30_emc_clk=533000” tag in the *cfg file ?

Forcing 3 cores off in the TaskManager has a bigger impact on temp compared to using DynamicCPUPowerOff registry key.
That do make sense, since the cores would be enabled once in a while when needed.

Possible to make the cores off always permantly and not just with the TaskManager?

I have added a excel sheet with some temp values from different settings and image versions.
The power usage is for the complete system incl. display and perf units.

link text

So DFS for memory and CPU cores disable would help a lot.


Would it be possible to lower it even more?

No, the we support only these two frequencies

Is it possible to run an update with only the “[general] t30_emc_clk=533000” tag in the cfg file ?

No, this is not possible, If you want to downgrade please just use the empty default BCT file called default_533.bct. Just run the update tool like update.exe /u default_533.bct. The file is part of the Update Tool download archive.

Possible to make the cores off always permantly and not just with the TaskManager?

Yes, you can set the number of cores in the boot loader config block. Just modify the pex.cpus. See more details here. Currently there is no library to enable / disable them dynamically during run time.

Thanks for the excel file that points out the results with the settings you tried. We will schedule the DFS for these clocks.