Realtime Clock Is Not Working

Clocksource: Switched to clocksource arm_global_timer
[    2.604539] rtc-ds1307 0-0068: hctosys: unable to read the hardware clock
[    3.650290] init: hwclock main process (60) terminated with status 1

Yes the thing worked.

root@armv7:~# hwclock -w
root@armv7:~# hwclock -r
Thu Dec  8 17:46:10 2016  -0.391057 seconds

Did you at least once actually write a valid date/time into the RTC? Have a look at e.g. the following:

root@apalis_t30:~# hwclock -r
hwclock: RTC_RD_TIME: Invalid argument
root@apalis_t30:~# hwclock -w
root@apalis_t30:~# hwclock -r
Fri Aug 12 12:12:16 2016  0.000000 seconds

Perfect. Thanks for letting us know!

After restart the hwclock shows the following error:

hwclock: ioctl(RTC_RD_TIME) to /dev/rtc to read the time failed: Invalid argument

Here is the dmesg | grep clock output:

2C-310 dynamic clock gating enabled, standby mode enabled
[    0.000043] sched_clock: 64 bits at 166MHz, resolution 5ns, wraps every 4398046511102ns
[    0.000095] clocksource: arm_global_timer: mask: 0xffffffffffffffff max_cycles: 0x2674622ffc, max_idle_ns: 440795203810 ns
[    0.076474] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.132673] PTP clock support registered
[    0.135452] clocksource: Switched to clocksource arm_global_timer
[    2.603816] rtc-ds1307 0-0068: hctosys: unable to read the hardware clock
[    3.548654] init: hwclock main process (60) terminated with status 1