I’m currently running V2.7 (QT 5.7.1). I added qtserialbus and qtserialport to local conf. Although qtserialbus exist in the meta-qt5 recipie and i can confirm it is properly compiled (I ran bitbake -v qtserialbus) it is not deployed.

oe-core/build/buildhistory/sdk/angstrom-glibc-x86_64-armv7at2hf-neon/meta-toolchain-qt5/target/installed-packages.txt does not contain qtserialbus and QT is complaining about the unknown package.


Please read this first.

I assume ‘I added qtserialbus and qtserialport to local conf’ means that you added them to the IMAGE_INSTALL variable with something like:

IMAGE_INSTALL_append = " qtserialbus qtserialport"

You could build the SDK with the image recipe you also use for the target image and -c populate_sdk and should then get all dev packages for all packages which are also deployed to the target, including qtserialbus.

Alternatively you could add additional packages to be deployed into the meta-toolchain-qt5 SDK’s target rootfs with something like:

RDEPENDS_packagegroup-qt5-toolchain-target_append = " qtserialbus-dev qtserialbus-mkspecs"

Alternatively you could backport this commit in meta-qt5.



Good to hear that you have a working solution.

If you want to explore the -c populate_sdk route:
Just delete all files in …deploy/sdk/ to get around ERROR: console-tdx-image-2.7.2-r0 do_populate_sdk: The recipe console-tdx-image is trying to install files into a shared area when those files already exist. as the third note here points out.


Thanks a lot for your support.
I thought that:

bitbake meta-toolchain-qt5
was supposed to prepare the SDK.

How ever I ran

bitbake -c populate_sdk

but it resulted in error. See Attached files.link text

Adding “RDEPENDS_packagegroup-qt5-toolchain-target_append” worked although QA reported a warning.
Backporting the commit worked as well.

Thanks a lot for your support.