Problems with FlexTimer 1 to 3 (with Cortex M4 on VF61)

I’m using eCOS 3.0 to develop firmware intended to run on the M4 core of a Colibri VF61…
I’ve managed to successfully use FTM0 and GPIOs.

When I try to use FTM1, 2 or 3 (using the same code I use for FTM0) they don’t start counting.

  1. I’ve tried enabling FTM0 and FTM2 clocks with

CYGHWR_HAL_VYBRID_CCM_P->cscdr1 = (1 << 27) | (1 << 25); //FTM0 and FTM2

But It seems to hang A5 core (and also M4 ??)

  1. “printing” CYGHWR_HAL_VYBRID_CCM_P->cscdr1 shows enabled clocks for both FTM0 and FTM1.

  2. Trying to “print” FTM1 registers, hangs M4 core.

¿Any suggestion? ¿Tutorial? ¿Example(s)?

Do you run something on the A5 core? The Linux PWM driver uses the FTM, and our default device tree uses the PWM for Backlight control. You might need to disable backlight/PWM in the Linux device tree.

Furthermore, you might need to register another interrupt handler.

How did you manage to run your code from Cortex-M4 from uBoot? I am using this link but nothing helps me from that link? There are some undefined steps in this link.

The line you are referring to is applicable for FreeRTOS only and not eCOS.

How can I disable that?

Please do not hijack old threads and use new posts for your queries.

Backlight/PWM can be disabled on Linux side by modifying device tree. Please have a look at the following article here.