Problem in vf61 recovery

I am using iris 1.1A develoment board to recover my colibri vf61 which doesnt boot at startup.
I am using following link to recover vf61.
(http://developer.toradex.com/knowledge-base/vfxx-recovery-mode#Iris_Carrier_Board_11A)
but problem is occur described below. how to fix my problem?

ant@ant-VirtualBox:~/Colibri_VF_LinuxConsoleImageV2.5$ ./update.sh -n -d /dev/ttyUSB0
Colibri VF rootfs detected
Put the module in recovery mode and press [ENTER]...

config file <vf_flash/vybrid_usb_work.conf>
parse vf_flash/vybrid_usb_work.conf
starting associating phase
association phase succeeded, response was 0x23454523
HAB security state: development mode (0x00000505)
== work item
filename colibri-vf_bin/u-boot.imx
load_size 0 bytes
load_addr 0x00000000
dcd 1
clear_dcd 0
plug 1
jump_mode 2
jump_addr 0x00000000
== end work item
main dcd length 8
sub dcd length 4

loading binary file(colibri-vf_bin/u-boot.imx) to 3f4074e8, skip=0, fsize=6eb18 type=aa

<<<453400, 453400 bytes>>>
failed (status 0x00000000)
jumping to 0x3f4078e8

Status seems to be not as expected. Never observed this error before.
Can you see U-Boot console on serial console after this ?
Can you brief your setup and steps?

My board does not boot at all. That’s why I am performing Recovery but it is also going wrong way.

update.sh -d … copies the U-Boot binary directly to modules RAM via debug UART port, so if the recovery mode is successful we can expect U-Boot prompt on debug UART port. Do you have other Colibri Vybrid module at your end ?

Yes I have Colibri VF61 and Iris Eval Board.

Can you try recovery procedure on that module ?

I already did. I follow these steps:

1) Shorting two pin on JP1 as described in link and bridging RTS and CTS of UART A.
2) Power up the module and then remove both Jumper appiled on step 1.
3) Now connect UART to linux PC and fire the following command.
./update.sh -n -d /dev/ttyUSB0

RTS/CTS need to bridged all the time during the recovery process.

From article:
“When starting the serial downloader utility remember whether you have RTS/CTS connected or bridged.”

Did the module worked when you first received it? Was there output on the serial console? All our modules go through extensive testing, it is highly unlikely that you receive a module which does not show anything on the serial console.

How do you connect your module with your host device exactly? If you use RS232 (UART_A), can you check your adapter and the plug orientation (red marking needs to be at pin 1).

If you use RS232, you typically have RTS/CTS, hence you should not use the -n parameter when downloading U-Boot.

What serial terminal emulator do you use? Did you check baud rate?

Yes It was working when we received that. In fact we were using it for months and then I wanted to change some configuration in linux and we flashed new linux also and it was also working perfectly. Then we tried to run FreeRTOS program on Cortex-M4 and then again we needed to build linux with reproc module and while loading that linux, we lost console. After that moment, we are trying to recover the module but nothing helps. Last command I fire on console was cfgblock create and then run update. After that it was showing resetting for almost 1 hour and then I pressed Reset button and then after I ain’t getting anything on console.

Yes I tried that too. Same result.

I searched whole community and documentation. There is no proper documentation to recover my VF61. Should I consider it dead?

Same problem here. Have you found the solution?