Problem booting from SD card on Colibri IMX7D

Hi! I have tried to boot from an SD card into my Iris 2.0 board using both a tdx-reference-minimal-image I built and another I’ve got from Toradex’s site.

In both cases I’ve got:

U-Boot 2019.07-3.0.4+g26d926eda0 (Apr 17 2020 - 21:32:25 +0000)

CPU:   Freescale i.MX7D rev1.3 1000 MHz (running at 792 MHz)
CPU:   Extended Commercial temperature grade (-20C to 105C) at 32C
Reset cause: POR
DRAM:  512 MiB
PMIC:  RN5T567 LSIVER=0x01 OTPVER=0x0d
NAND:  512 MiB
Loading Environment from NAND... OK
In:    serial
Out:   serial
Err:   serial
Model: Toradex Colibri iMX7 Dual 512MB V1.1D, Serial# 06786546
Net:   FEC0
Hit any key to stop autoboot:  0 
Colibri iMX7 # 
Colibri iMX7 # run sdboot
Booting from MMC/SD card...
7035192 bytes read in 320 ms (21 MiB/s)
Colibri iMX7 #

What could be going wrong here? I also tried with a USB mass storage device and could not find the image in it.

I confirm both the SD card and the USB mass device have two partitions with the correct formatting.

I have also read somewhere else that I should manually copy the files in the boot partition to rootfs/boot/
I did that and I’m still getting the same behavior.

You are using older U-Boot. Isn’t there distro_bootcmd defined?

Colibri iMX7 # pri distro_bootcmd
distro_bootcmd=for target in ${boot_targets}; do run bootcmd_${target}; done

The checking boot_targets reveals should reveal mmc0:

Colibri iMX7 # pri boot_targets
boot_targets=mmc0 usb0 dhcp

So run bootcmd_mmc0 works for me on U-Boot 2020.07. If indeed sdboot is right command in your U-Boot, then perhaps you have edited something in U-Boot environment, which prevents sdboot? Try resetting environment to default and try sdboot again:

env default -a

Thanks a lot. Indeed I was given a SoM board which was not pristine.