PPP dialing 3G/4G in Colibri Vf61

Earlier was using V2.7 BSP and able to dial 3G/4G donlge using PPP .But after updating BSP to 2.8b6.183-20190331 , PPP dialing is not success. After dialing getting failed from ISP side but the same dongle is working with V2.7 with same configurations.

Using Huawei 4G Dongle (E3372h) In both OS Versions (V2.7 & 2.8) its able to detect the dongle. USB id for dongle is 12d1:157c .Then using usb_modswitch to convert to modem mode.

Connection log is attached for both OS versions.link text

hi @abhil

Could you provide the hardware version of your module? Which carrier board are you using?
Have you done any changes to the Software? If yes, please share these changes?

PPP dialing is not success

How are you dialing in? Could you share any commands or scripts used?

Thanks and best regards,

Hardware Version: Colibri Vf61(1.2A) on Evaluation Kit (V3.1A)

Using pppd to dial with chatsript.
Please find the attached dialing scripts.

link text

Hi @abhil

Thanks for the files and the patience.

We bought the same USB Dongle as you and tested it on Bsp 2.8b6.
Usually if you switch to the new Huawei Mode, then you get a ethernet interface which you can access using a Webbrowser and change the configuration. The Ethernet interface can be used to connect to the internet.

Alternatively you can apply the following command to switch the modem to the correct mode:

usb_modeswitch -v 12d1 -p 1f01 -P 14db -M 55534243123456780000000000000011063000000100010000000000000000

I would recommend you to use modemmanger or wvdial to do the dialup connection instead of a PPP dialling, since PPP dialling is obsolete.

Note: If the connection to modem is not working then you might have to stop the application ofonod.

Best regards,

is there any feed to install wvdial . or need to manualy compile and add ?

Hi @abhil, you need to do build either the wvdial package or a complete image including the wvdial package using Yocto.

hi jaski,
If we use wvdial .Its also using pppd on background for dialing right ? So will it get solved or same issue can happen. ??

Tried building wvdial V1.61 . but unable to make.its giving dependency errors.
Do you have any reference for compilation.

HI abhil,
I tried to install wvdial and it was working fine.

How exactly have you build wvdial?

Best regards,

Hi jaski,

Building with normal cross compilation method.
export PATH and CC
configure, make, make install to prefix directory then transfer to SOM .
but its asking for wvstream as dependency. Compiling the wvstream is pointing to openssl and so on.

Can you provide some alternate method.

You should do OpenEmbedded Build.

Hi Jaski,

Sory for the delay.Was not having OE setup. So i arranged all the required things and successfully compiled new image with wvdial.
With wvdial also am geting same issue what i faced with pppd.

vendor:0x12d1 product:0x157c
usb_modeswitch -v 12d1 -p 157c -P 1506 -M 55534243123456780000000000000011062000000100000000000000000000
lsusb command is showing that device is turned to modem mode

Tried with wvdialconf for default configuration, but it was not detecting. So given manual configuration.
Details are included in the log file with steps i tried. link text
Please see the attached log files link text

Hi @abhil

Can you try to recompile the kernel with the following option enabled?
You can enable that in your .config file when compiling the kernel:

I think in this case even your initial approach with ppp could work.


Hi Stefan,

Yes i tried enabling CONFIG_PPP_FILTER=y
Please find the attached .config filelink text

Is there any option to check this option is enabled in kernel after compilation.

hi @abhil

Yes you can check this with zcat /proc/config.gz > config.txt

Best regards,

Yes its compiled,












CDC also enabled.



Perfect. So does it work?

Unfortunately its still not working.
Am totally clueless on this issue.

Also noticed another point.Once we connect datacard with SoM, the same is not on PC also (Linux PC using pppd dialing). Again we need to use huaewei datacard software(windows PC) and select the network type as shown in uploaded screenshot alt text

Attached is the latest pppd log with PPP Deflate enabled.

Can you connect some dongle at your side and once again ensure it will work.
Same step i will also follow, either PPPD or WVDIAL method.

link text

Hi @abhil

We will try to get one of this dongle and try this on Vybrid module. Our tests on iMX6 were successful. We will come back next week to you. Thanks very much for your patience.

Best regards,

Hi Jaski.

Are you able to progress on this .