Permission denied after clean Build

Hi,
We are having errors building our modules with latest rocko.
Previously, as a workaround, this commit was being cherry-picked on top of older rocko release with no problems.

Now, including the following line in one of our recipes apparently solved the problem:

do_compile[depends] += "virtual/kernel:do_shared_workdir"

But building on our production build server, results in the same kind of problem: build_error_file
And building on a 3rd machine generates the same error, but in another similar recipe.

Seams like dependency/concurrency problem: build server has more cores/parallel tasks and probably our recipes (and probable dependency) run in parallel.

This post seems to describe a similar issue.

Is there any particular reason for you to set this question on private? With private questions, there is no way for the community to provide feedback or profit from any feedback.

hi @Fabiano.Ferronato

You could check for the dependency with the following commands for your recipe with the following command to understand the Issue: bitbake -g -u taskexp <recipe-or-image-name>.

Try please also to limit the cpu for the build to find out for how many cpus/concurrent threads the build is still working.

Thanks and best regards, Jaski