On/Off button on Colibri Evaluation Board

I found an issue with the On/Off button mounted on Colibri Evaluation Board (rev 3.2).
If you push the button for a short time (a quick press and release), everything works fine and the colibri VF61 module boots.
If you press the button for a long time (you can do some tests holding it pressed), sometimes the module doesn’t boot.
When this happens, the colibri module can boot only if you power off the board and you wait 5 or 6 seconds before powering it on. It seems that you need to wait for the discharge of some component.

Are you able to reproduce this issue?
Could you provide a fix?

I tested here at my end but did not able to reproduce the issue.
Pressed the power button to switch ON about 3-5 seconds modules boots up fine. Even pressed the power button to switch OFF for about 3-5 seconds all went fine.
I did this for about 5 times.

If you have any other Evaluation board can you please check on it?

I investigated deeper the issue, and it happens only if an USB cable connects the Evaluation board X29 to the PC (X29 is the port used for remote connection with Windows Mobile Center).
If the cable is not connected, the boot works properly.

Thanks for your support

@rajat.tx were you able to reproduce the issue connecting the USB cable?

@vix I tested by connecting USB cable on X29 as well as on X27. But, did not able to reproduce the issue. Everything worked well and module was booting fine.

We checked the schematic across X29 if in case there is feedback from the computer but there is nothing like that.
Can you try connecting oscilloscope across power button SW7 and check if there is debounce happens or not.
It may happen that you have been pressing the power switch for long but in actual debounce happens.

I checked with an oscilloscope, but the signal across SW7 seems ok.
So I investigated deeper, and it seems that issue is related to the communication with Windows Mobile Center on my Win7 laptop: if an USB cable is connected to X29, Windows Mobile Center starts automatically as soon as WinCE 6 boots on the Colibri module.
It seems that when the module can’t boot, Windows Mobile Center is somehow hung or not responsive on my PC.
Since you can’t reproduce the issue, let me know if I can provide further details to help you.

Same issue, using Eval board 3.2, CE7, T30. Most of the time I need to use the reset button to get it too boot.

Makes no difference if Windows center is on or off, USB or not

Hello @raja.tx, I have new information on this issue.
I hope they are useful to you to understand if this behavior hides some bigger issue.

First of all, the issue happens when the evaluation board is powered off but some power supply is applied to some pins of the VF61.
This can happen, as an example, when USB cable is connected from the PC to X29 connector (signal USB0_VBUS_DETECT).
Another example on the Evalution Board is if I apply a DC value of +3.3 V (driven with high impedence) to pin SODIMM_30. This simulates an output.
I measured that when the Evaluation board is powered off, a current of more or less 16 mA is driven into VF61 through this pins (USB0_VBUS_DETECT or SODIMM_30).

My guess is that this current gives some problem to the VF61 when it boots (not 100% of the times, but more frequently if you push and hold down the button SW7 for a couple of seconds).
Some months ago I was wrong: the VF61 boots (I can see from the extended debug messages), but the RGB interface which drives my EDT display doesn’t work as expected.
Most of the times the display is completely white, but sometimes I can see images with some missing colors.
I don’t know if some other peripherals are affected somehow.

Based on the new information, are you able to reproduce this issue?
Do you think that some protection is needed on USB0_VBUS_DETECT pin when VF61 is powered off but USB voltage is applied by the PC connected to X29?

Thanks in advance.


Thank you for contacting the support.

We are able to reproduce the issue only by connecting external 3.3V to the SODIMM 30.

What is the status of LED13 and LED14(near to the Power inductors L20 and L21) at issue state?

We would like to know the use cases related to that. Will you connect external 3.3V to SODIMM 30 pin? Also, USB OTG cable use case?

We are looking into the issue and please wait for few days.

thank you for your help investigating this issue.

At issue state, both LED13 and LED14 are ON with green color.

On my system (Evaluation Board + VF61 module), when I connect external 3.3V to SODIMM 30 the issue happens 100% of the times. But the external voltage is applied directly to the pin of module.

With USB cable, the issue happens sometimes, and sometimes it doesn’t; on your system the issue doesn’t happen.

Looking to the chematics of Evaluation Board, the USB 5V is reduced to 3.3V through a R73=560R and R74=1k. Maybe 560R is near the limit where the issue happens or not.

Could you see the issue if you reduce R73 and R74 to 280R and 500R, for example?

On the use cases:

  • on the evaluation board I connect directly a waveform generator to SODIMM 30; on the real case I have an external device (which can bring voltage even if VF61 is powered off), but the imput circuit is protected. No direct connection to the pin, so I think this is not a real danger
  • USB OTG is a real case because I want to see my VF61 device as mass storage when I connect it to a PC and I want to download data from VF61 device to a mass storage device.

If you can reproduce the issue, you can investigate and suggest different design circuit (if needed).

You’re right.

I forgot to set SODIMM 137 (PAD_102) as OUTPUT high.

Now it works as expected.


Thank you for your reply.

Do you want USB Host and Client functionality or only Client functionality?

If you want to use only client functionality then we have a workaround for you.

It doesn’t need USB_C_DET signal(remove SODIMM 137 jumper, related circuitry) and set that pin as GPIO output and 1. This will make that port as permanent USB Client.
and set registry as shown in below


Please let me know your feedback on this.


In my project I need that the device with Colibri VF61 module is seen as a mass storage device when connected to the PC.

But It would be very useful if when connected, Windows Mobile Device Center starts and can handle the device.

I followed your suggestion, but after I removed SODIMM 137 jumper, “USB status” popup is not shown anymore on the BF61 and Windows Mobile Device Center doesn’t start on my PC.

In this scenario, I can’t see anymore the VF61 as mass storage device from my PC.

Is there something wrong in this approach?


one more question: since I don’t need Host functionality, can I use SODIMM_129 (which is USBH_PEN for Colibri family) as a general purpose INPUT?

I configured in this way in the bootloader, but with an oscilloscope it seems that Win CE reconfigures it as a low output (standard behavior for USBH_PEN, I think).

Should I set something else on WinCE side?

Dear @vix
Your question is not related to the topic of this post On/Off button on Colibri Evaluation Board. Please open a new question.
Regards, Andy

this is not completely true.

As a matter of fact, the USB Host functionality is partly responsible for the issue I see on Off/Off button.

Anyway I’m going to open a new topic.


Did you set SODIMM 137 pin as GPIO output and 1?