Nothing append on screen even is container is running with Torizon-samples library

Hello everyone,

We just bought a Verdin imx8mp with a Mallow Carrier board and I am trying to run some example code from the Torizon-samples library to familiarize myself with the concept of multiple container.

I am following the Example: Multi-Container Application with Grafana, Collectd, and InfluxDB tutorial for the grafana and weather example.

Unfortunately, when I run docker-compose up -d with the grafana example, it seems to be running but only a black screen with a mouse open on the display.

I am using WSL on Windows 11. And Docker Client version 24.0.5.

Do you have any idea where that could come from ?

Thanks a lot,

Greetings @coline,

This example was originally designed for TorizonCore 5. I guess it has not been updated yet to work properly for TorizonCore 6. I assume you’re on a TorizonCore 6 correct?

That said I was able to get it working again with some simple changes. After you copy the example source code to your device you want to make the following changes:

  • Edit your docker-compose.override.yml such that it looks like this:
# this override brings up Grafana on a local display
version: "2.4"
    container_name: weston
    image: torizon/weston-vivante:3
    command: --tty=/dev/tty7
    # Required to get udev events from host udevd via netlink
    network_mode: host
      - type: bind
        source: /tmp
        target: /tmp
      - type: bind
        source: /dev
        target: /dev
      - type: bind
        source: /run/udev
        target: /run/udev
    # Add device access rights through cgroup...
      # ... for tty0
      - 'c 4:0 rmw'
      # ... for tty7
      - 'c 4:7 rmw'
      # ... for /dev/input devices
      - 'c 13:* rmw'
      # ... for /dev/dri devices
      - 'c 226:* rmw'
      # ... for /dev/galcore device on i.MX8
      - 'c 199:* rmw'

    container_name: kiosk
      - MACHINE
    image: torizon/chromium:3
    command: --window-mode http://grafana:3000
      - seccomp:unconfined
      - frontend
      - type: bind
        source: /tmp
        target: /tmp
      - type: bind
        source: /var/run/dbus
        target: /var/run/dbus
      - type: bind
        source: /dev/galcore
        target: /dev/galcore
      - weston
      - grafana
      - influxdb
    shm_size: '256mb'
      # ... for /dev/galcore device on i.MX8
      - 'c 199:* rmw'
  • Then edit the Dockerfile so it looks like this:
ARG IMAGE_ARCH=linux/arm64
ARG IMAGE_TAG=3-bookworm


RUN apt-get -y update && apt-get install -y --no-install-recommends \
    libmnl0 \
    collectd \
    && apt-get clean && apt-get autoremove && rm -rf /var/lib/apt/lists/*

CMD ["collectd","-f"]

With this once I ran docker-compose up -d I was able to see the Grafana UI on my local HDMI display. I will bring this up with our team internally and see if we can update this example.

Best Regards,

Hi @jeremias.tx !

Unfortunately I still have the same problem even with your modifications :confused:

Best Regards,

Are you sure you copied everything correctly and re-built everything from scratch for the example? This is all the modifications I made to the source and it works for me to show the Grafana UI. I did this on TorizonCore 6.3.0 with a Verdin i.MX8M Plus so it should be the same for you.

In your case could you check if any containers are not running and if so check the logs for these containers.

EDIT: Also actually I just checked, and the original unmodified source works fine as well for showing the Grafana UI. Though it’s a a little buggy since the original source wasn’t designed for TorizonCore 6 as I said earlier. Either way though I have something showing on my local display, so I’m not really sure what’s happening on your setup. Did you also make sure to stop any previously running containers before starting the demo containers?

Best Regards,