Not able to boot from USB iMX7d

Hi,

I am not able to boot via USB today… and seeing strange issue says unable to enumerate USB device, whereas same usb works from linux after boot.
Could you please suggest what could be wrong here?

U-Boot 2016.11-1.8.0+g07edca0bb8 (Oct 19 2018 - 13:34:21 +0000)

CPU:   Freescale i.MX7D rev1.3 996 MHz (running at 792 MHz)
CPU:   Extended Commercial temperature grade (-20C to 105C) at 38C
Reset cause: POR
DRAM:  512 MiB
PMIC:  RN5T567 LSIVER=0x01 OTPVER=0x0d
MMC:   FSL_SDHC: 0
Using default environment

In:    serial
Out:   serial
Err:   serial
Model: Toradex Colibri iMX7S/D
Model: Toradex Colibri iMX7D
Serial Downloader recovery mode, using sdp command
Net:   FEC0
Error: FEC0 address not set.

Hit any key to stop autoboot:  0
SDP: initialize...
SDP: handle requests...
Downloading file of size 21374744 to 0x82100000... done
Downloading file of size 300 to 0x82000000... done
Jumping to header at 0x82000000
Header Tag is not a IMX image
## Loading kernel from FIT Image at 82100000 ...
   Using 'config@imx7d-emmc' configuration
   Trying 'kernel@1' kernel subimage
     Description:  Linux Kernel 4.1
     Type:         Kernel Image
     Compression:  uncompressed
     Data Start:   0x821000dc
     Data Size:    5308472 Bytes = 5.1 MiB
     Architecture: ARM
     OS:           Linux
     Load Address: 0x81000000
     Entry Point:  0x81000000
     Hash algo:    md5
     Hash value:   910fc4bfe6325ca943e1af0824a15957
   Verifying Hash Integrity ... md5+ OK
## Loading ramdisk from FIT Image at 82100000 ...
   Using 'config@imx7d-emmc' configuration
   Trying 'ramdisk@1' ramdisk subimage
     Description:  SquashFS RAMdisk
     Type:         RAMDisk Image
     Compression:  uncompressed
     Data Start:   0x826101fc
     Data Size:    15929344 Bytes = 15.2 MiB
     Architecture: ARM
     OS:           Linux
     Load Address: unavailable
     Entry Point:  unavailable
     Hash algo:    md5
     Hash value:   bf0a406d6fa572c48f601023ca980bd2
   Verifying Hash Integrity ... md5+ OK
## Loading fdt from FIT Image at 82100000 ...
   Using 'config@imx7d-emmc' configuration
   Trying 'fdt@imx7d-emmc' fdt subimage
     Description:  Colibri iMX7 Dual 1GB eMMC Device Tree
     Type:         Flat Device Tree
     Compression:  uncompressed
     Data Start:   0x83557184
     Data Size:    45372 Bytes = 44.3 KiB
     Architecture: ARM
     Hash algo:    md5
     Hash value:   b34140d2c5400aef8309a51bb7486030
   Verifying Hash Integrity ... md5+ OK
   Booting using the fdt blob at 0x83557184
   Loading Kernel Image ... OK
   Loading Device Tree to 8fff1000, end 8ffff13b ... OK

Starting kernel ...

[    0.349874] fec 30be0000.ethernet (unnamed net_device) (uninitialized): Invalid MAC address: 00     :00:00:00:00:00
[    0.365929] imx_usb 30b10000.usb: Can't register ci_hdrc platform device, err=-517
Running /etc/rc.local...
Colibri-iMX7_ToradexEasyInstaller_1.8-20181019

Welcome to Toradex Easy Installer

This is a Linux based installer for Toradex modules. Currently the
installer does not have a serial console interface. You can use the
Toradex Easy Installer through any of the available display interfaces
using USB mouse/keyboard or via network using VNC. Use:
  # ip addr show eth0
to display the Ethernet IP address or use USB RNDIS at IP 192.168.11.1.

/ # [    2.030537] usb usb1-port1: cannot reset (err = -32)
[    2.035548] usb usb1-port1: cannot reset (err = -32)
[    2.041812] usb usb1-port1: cannot reset (err = -32)
[    2.046809] usb usb1-port1: cannot reset (err = -32)
[    2.051829] usb usb1-port1: cannot reset (err = -32)
[    2.056794] usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
[    2.063405] usb usb1-port1: cannot reset (err = -32)
[    2.069562] usb usb1-port1: cannot reset (err = -32)
[    2.074576] usb usb1-port1: cannot reset (err = -32)
[    2.079560] usb usb1-port1: cannot reset (err = -32)
[    2.084567] usb usb1-port1: cannot reset (err = -32)
[    2.089533] usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
[    2.096123] usb usb1-port1: cannot reset (err = -32)
[    2.101134] usb usb1-port1: cannot reset (err = -32)
[    2.106127] usb usb1-port1: cannot reset (err = -32)
[    2.111171] usb usb1-port1: cannot reset (err = -32)
[    2.116215] usb usb1-port1: cannot reset (err = -32)
[    2.121228] usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
[    2.127815] usb usb1-port1: cannot reset (err = -32)
[    2.132842] usb usb1-port1: cannot reset (err = -32)
[    2.137868] usb usb1-port1: cannot reset (err = -32)
[    2.142916] usb usb1-port1: cannot reset (err = -32)
[    2.147927] usb usb1-port1: cannot reset (err = -32)
[    2.152936] usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
[    2.159514] usb usb1-port1: unable to enumerate USB device

What exactly is it that you are trying to achieve?

It looks like you are running the Toradex Easy Installer from the USB recovery mode which seems to start just fine.

What exactly is it that does not work as expected?

Hi @marcel.tx
I have copied all the files (Colibri-iMX7-eMMC_Console-Image-Tezi_2.8b6) into USB and VNC to flash my kernel image into module.
But I do not see USB getting detected in boot selection. it only shows online images as I have Ethernet connected.

And you did previously unzip/untar the image to your USB memory stick which you plug in once the Toradex Easy Installer is started as outlined here?

https://developer.toradex.com/software/toradex-easy-installer#providing-the-images

Yes, I did this many times was working earlier.
Even now I can see the installer but don’t see USB image detecting. Seems something went wrong I am trying to figure out…

What exact hardware (module and carrier board) versions of things are you talking about? Which exact USB port are you using? What exact USB memory stick are you using?

Please find details below:
Colibri iMX7d 1GB eMMC, Colibri Evaluation Board Rev. 3.2.
I tried from all the four USB port.
it’s 16GB Sandisk USB FAT32 (which was working before), I tried another USB too but same error.

[ 2.050666] usb usb1-port1: cannot reset (err = -32)

attaching dmesg log for you to understand better. it seems there is some problem in USB port. link text

One thing you could try is first installing the very latest Toradex Easy Installer 2 beta nightly from our CI feed, rebooting and attempting to install your image from the USB memory stick again.

Thank you for the response… I think it’s some board related issue as we did lots of changes… so when I plug two USB (one dummy) it boots.
Thank you & sorry for troubling you.

Thanks for you Input.

Best regards,
Jaski

i am seeing exactly these logs using a weak power supply.

Thanks for your Input. You mean a weak power supply for the USB Hub/Device?

With some weak general powersupply i had lying around. 12V/1500mA
Colibri Eval Board V3.2B + imx7 1G

Thanks for your feedback.