No device compatible, Apalix imx6q VS code

Hello :slight_smile: ,

Here is my equipment:
-Board Ixora v1.1A
-Toradex Apalis iMX6Q 2GB IT

I followed exactly 4 time the tutorial:

But during the build I have errors :

-F# server
-No device compatible
-warning NETSDK1179: One of ‘–self-contained’ or ‘–no-self-contained’ options are required when ‘–runtime’ is used.

The ssh connection works well, the device is well connected via ethernet and the image of my project is well launched on the docker torizon

Screenshot 2023-03-14 124642

Hi @Fonky ,

Maybe you would like to test out the new version of the extension. You can find it in the extensions of VisualStudioCode. There you can search for “ApolloX”.

You can give it a try and see if that improves things.

Best Regards
Kevin

Hi @kevin.tx ,

Unfortunaly this extension dont match with my computer,
Is there a way around this rule?

Hi @Fonky ,

Yes there is. My bad I forgot that you can’t do it like this on Windows.

You would have to follow the instructions here:

Keep me updated.

Best Regards
Kevin

1 Like

Hi @kevin.tx ,

can I work in a linux VM?
I also have a pc with linux Debian 11 but with an old i3

Hello @Fonky ,
You can install ApolloX on a Linux VM and work from there.
But to give you an idea of the HW and SW requirements for this case on a very recent training:

  • 64-bit Intel or AMD processor (4 CPUs).
  • 16GB RAM.*
  • 50GB storage.*
  • VirtualBox 7.0+.*
  • No VPN, firewall or antivirus software running on the host OS (or the ability to disable it if required), as it might cause network connectivity issues with the development kit.

Howewer, nothing stops you from trying with your HW and sharing your results here. If you try it please let us know the outcome.

Best regards,
Josep