.Net Application debugging with custom network

Hi All,

I am facing issues while debugging the application using VS Code plugin for a .net application.

I am trying to use a custom network for the .net application. I see that if I specify the custom network using networks option in the configuration the debugger fails to start the debugging session with following error in the debug console

Starting: "ssh" -T -p %{port} -i %{keypath} -o StrictHostKeyChecking=no -o "UserKnownHostsFile /dev/null" %{devicelogin} "/vsdbg/vsdbg --interpreter=vscode"
Error from pipe program 'ssh': Bad port '%{port}'
The pipe program 'ssh' exited unexpectedly with code 255.

As you can see the environment variables specified in launch.json are not substituted correctly.

Any idea what might be wrong?


Greetings @gauravks,

I attempted to reproduce your issue but I was unable, however I did encounter a different issue entirely in the attempt.

For context I did the following (this is on the early access version of the extension):

  • Create a new .NET console project
  • On my target device create a docker network called “test”
  • Add test to the networks configuration in the extension
  • Hit F5 to start debug

After this I then get the following error:

Error (525) - Docker exception: 500 Server Error for Internal Server Error ("error gathering device information while adding custom device "test": no such file or directory")

I then use docker inspect to check the created container. It seems instead of adding test to the networks it instead added it to devices. This is possibly related to the other issue you’ve reported with the extension.

In any case I’m not able to reproduce your error but there does seems to be something wrong with the networks configuration option.

I’ll report this issue tour extensions teams. Hopefully our two issues here are related and not entirely different since I’m unable to reproduce yours.

Best Regards,

@gauravks The latest release of the early access extension (V1.4.265) should now have the networks configuration option working properly again. If you could give this a try and let us know how it works for you, that would be appreciated.

Best Regards,