My Openembedded core fails with one task T20

I have set the environment for open embedded-core build and then

bitbake -k angstrom-qt-x11-image

I am trying to make a QT build environment. Hello world programe without QT is Ok in my case.
the build takes hours for the first time and then on repeats it becomes faster.
(I am new to linux)
Result is like this

ERROR: Checksum failure fetching
ERROR: Function failed: Fetcher failure for URL: ''. Checksum mismatch!
File: '/home/serpent/oe-core/build/downloads/videoproto-2.3.2.tar.bz2' has md5 checksum 8ca53595df06c1e1a4fc4a5ff460cc8f when e658641595327d3990eab70fdb55ca8b was expected
File: '/home/serpent/oe-core/build/downloads/videoproto-2.3.2.tar.bz2' has sha256 checksum 82e08655e790c6768410b4257e9b57091f365b44627c73345fb3a56dc0bacef8 when 8dae168cb820fcd32f564879afb3f24d27c176300d9af66819a18265539bd4b6 was expected
If this change is expected (e.g. you have upgraded to a new version without updating the checksums) then you can use these lines within the recipe:
SRC_URI[md5sum] = "8ca53595df06c1e1a4fc4a5ff460cc8f"
SRC_URI[sha256sum] = "82e08655e790c6768410b4257e9b57091f365b44627c73345fb3a56dc0bacef8"
Otherwise you should retry the download and/or check with upstream to determine if the file has become corrupted or otherwise unexpectedly modified.

ERROR: Logfile of failure stored in: /home/serpent/oe-core/build/out-glibc/work/armv7at2hf-vfp-angstrom-linux-gnueabi/videoproto/1_2.3.2-r0/temp/log.do_fetch.29252
ERROR: Task 3201 (/home/serpent/oe-core/build/../stuff/openembedded-core/meta/recipes-graphics/xorg-proto/, do_fetch) failed with exit code '1'
NOTE: Tasks Summary: Attempted 2237 tasks of which 2232 didn't need to be rerun and 1 failed.
NOTE: Writing buildhistory
Waiting for 0 running tasks to finish:

Summary: 1 task failed:
  /home/serpent/oe-core/build/../stuff/openembedded-core/meta/recipes-graphics/xorg-proto/, do_fetch
Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

May I ask what exact version of our BSP you are trying to build (e.g. how did you repo init your stuff)?

I could download the file manually here and it had the correct checksums. Maybe it was a glitch in the internet connection to said server.

What happens if you clean and build just the recipe which failed? e.g.

bitbake -c cleanall videoproto
bitbake videoproto

Should that work you could restart the image build with

bitbake -k angstrom-qt-x11-image

I followed the below instructions in toradex site

 mkdir oe-core
  cd oe-core
  repo init -u -b LinuxImageV2.6
  repo sync

  . export


This was the output when I tried .

 serpent@LinuxSerpent:~/oe-core/build$ bitbake -c cleanall videoproto bitbake videoproto
Loading cache: 100% |###########################################| ETA:  00:00:00
Loaded 3063 entries from dependency cache.
ERROR: Nothing PROVIDES 'bitbake'

Summary: There was 1 ERROR message shown, returning a non-zero exit code.


Sorry, those bitbake commands were meant to go on separate lines.

Then I rebuild again

Summary: 6 tasks failed:
  /home/serpent/oe-core/build/../stuff/openembedded-core/meta/recipes-graphics/xorg-proto/, do_fetch
  /home/serpent/oe-core/build/../stuff/openembedded-core/meta/recipes-multimedia/libtheora/, do_fetch
  /home/serpent/oe-core/build/../stuff/openembedded-core/meta/recipes-devtools/orc/, do_fetch
  /home/serpent/oe-core/build/../stuff/openembedded-core/meta/recipes-graphics/xorg-lib/, do_fetch
  /home/serpent/oe-core/build/../stuff/openembedded-core/meta/recipes-multimedia/libsamplerate/, do_fetch
  virtual:native:/home/serpent/oe-core/build/../stuff/openembedded-core/meta/recipes-devtools/orc/, do_fetch
Summary: There were 12 ERROR messages shown, returning a non-zero exit code.

Have you tried the following as @max.krummenacher suggested?

bitbake -c cleanall videoproto
bitbake videoproto

If you keep having further issues we would need full log files to be able to analyse what is truly going on.