M4 is not working

Hello All

I am using som module Verdin imx8mm v1.1 with Verdin development board v1.1
I am trying to check M4 in linux but i am not able to get any messages in ttyUSB2.

I am doing the following command in ttyUSB3

Verdin iMX8MM #
Verdin iMX8MM # ls mmc 1
805 hello_world.bin
27980 freertos_event.bin
29160 freertos_generic.bin
35924 freertos_uart.bin

4 file(s), 0 dir(s)

Verdin iMX8MM # setenv m4addr 0x7e0000
Verdin iMX8MM # saveenv
Saving Environment to MMC… Writing to MMC(0)… OK
Verdin iMX8MM # fatload mmc 1 0x48000000 hello_world.bin
805 bytes read in 18 ms (43 KiB/s)
Verdin iMX8MM # dcache flush
Verdin iMX8MM # cp.b 0x48000000 ${m4addr} 0x20000
Verdin iMX8MM # bootaux ${m4addr}

Starting auxiliary core stack = 0xA9BC7BFD, pc = 0x910003FD…

Verdin iMX8MM #


@asif ,
We are trying to reproduce the issue. We will get back to you as soon as possible.

Hi @asif ,

I was not able to reproduce the issue as it worked for me after following the steps mentioned here and I was able to see “hello_world” on my /dev/ttyUSB3 (sometimes port can change if they are already occupied).
Did you recheck that you downloaded the correct SDK.
Please check the similar issue
There is no modification needed in the code, it should work as it. Please recheck at your end.

Hello Sahil

Thanks for your mail.

For me now it is working.

The problem was with minimal linux image it was giving the problem. with multimedia linux version it is working.



Hi @asif ,
Nice to hear that the issue has been solved.