M4 Control Tool for i.MX platforms

Hi there,

I’ve trying to build the m4ctrl application and kernel module according to the indications here without success.

Basically, I first used openEmbedded to get a Linux image for the Colibri iMX8QXP (dunfell). I configured the compilation environment variables to:

  • SOC=IMX8QXP
  • ARCH=arm64
  • KDIR=~/oe-core/build/tmp/work/colibri_imx8x-tdx-linux/linux-toradex/5.4.154+gitAUTOINC+c65f162295-r0/build/
  • CROSS_COMPILE=gcc-arm-9.2-2019.12-x86_64-aarch64-none-linux-gnu/bin/aarch64-none-linux-gnu-

Then, I run make and get the error:

make[2]: Entering directory ‘/home/ebers/oe-core/build/tmp/work/colibri_imx8x-tdx-linux/linux-toradex/5.4.154+gitAUTOINC+c65f162295-r0/build’
CC [M] /home/ebers/repo/m4ctrl/kernel/m4ctrl_dev.o
/home/ebers/repo/m4ctrl/kernel/m4ctrl_dev.c:18:10: fatal error: soc/imx8/sc/sci.h: No such file or directory
18 | #include <soc/imx8/sc/sci.h>
|

Has anyone tried getting this module for this specific configuration?

Any help is appreciated.

Víctor

Hi @vic !

This m4ctrl is NXP’s software and they don’t update it since 2017 (m4ctrl - M4 Control Tool for i.MX platforms)

From their about page you can see that they reference kernel 4.9, which has the soc/imx8/sc/sci.h.

On kernel 5.4 it is not there.

So, I would say that NXP didn’t update this m4ctrl for 5.4 kernel.

Best regards,