Limiting VF50 to 10Mb/s?

Does anyone know how to set maximum speed for the FEC on the VF50? I tried adding max-speed = <10>; to the vf-colibri.dtsi file in the &fec1 but it doesn’t change it even though it compiles.

The max-speed property needs to be assigned to the PHY, not the MAC (FEC), see also Documentation/devicetree/bindings/net/phy.txt. Something like this should work:

&fec1 {
	phy-mode = "rmii";
	phy-handle = <&ethphy0>;
	phy-supply = <&reg_module_3v3>;
	pinctrl-names = "default";
	pinctrl-0 = <&pinctrl_fec1>;

	mdio {
		#address-cells = <1>;
		#size-cells = <0>;

		ethphy0: ethernet-phy@0 {
			reg = <0>;
			max-speed = <10>;

Hi Paul
Which git branch exactly are you using to do the compilation.

Sorry for the delay - these are what we’re using for source:

Which we get from git:// and git://


Hello Stefan,

I get this when it compiles:

Warning (reg_format): "reg" property in /soc/aips-bus@40080000/ethernet@400d1000/mdio/ethernet-phy@0 has invalid length (4 bytes) (#address-cells == 2, #size-cells == 1)
Warning (avoid_default_addr_size): Relying on default #address-cells value for /soc/aips-bus@40080000/ethernet@400d1000/mdio/ethernet-phy@0
Warning (avoid_default_addr_size): Relying on default #size-cells value for /soc/aips-bus@40080000/ethernet@400d1000/mdio/ethernet-phy@0

I tried putting the #address-cells and #size-cells under ethphy0 but got the same error.

Searching for someone else with this didn’t yield anything yet other than finding that #address-cells defaults to 2, and #size-cell defaults to 1. Looking through the code it appears that 10MB is handled but I am having a hard time finding the DT language. Do you know if there is a NXP/FSL document somewhere that talk about this?

Hi Paul

I compiled the linux build with changed device tree without any warnings. Do you have other local changes in your branch?

Do you mean in the device tree dtsi files? Yes, adding gpio, defining toush screen interface, etc. Nothing on the ethernet interface.

I can try a fresh copy - without any changes.

I’ll able to try this week when I return from travelling


I can get a new vanilla copy to compile, but when booting says there is no kernel space…

Hi Paul,
How did you compile? Did you change any files by yourself when building? Please send a log of boot sequence.