Ixora MicroSD Card Issue

I’m trying to update a linux image via microSD card on my Ixora V1.1A carrier board with an Apalis T30 module.

However, when running the run distro_bootcmd to invoke the Easy Installer, I get the following error:

mmc_change_clock: timeout error
mmc_send_cmd_bounced: waiting for status update

I’ve tried different Apalis T30 modules therefore I believe it to be an issue with the Ixora carrier itself.

There isn’t really much in the way of circuitry related to the microSD receptacle, my guess is that its probably due to one of the series resistor arrays going open circuit but this seems reasonably unlikely - based on experience.

This update mechanism/Ixora carrier board has been working flawlessly for months. Relevant anti-static precautions are observed when inserting/removing the microSD card so I’m a little puzzled as to whats changed.

I’ve also tried resetting the environment vars using env default -a; saveenv; reset but nada!

Greetings @kwebster83!

This is weird, I’m gonna need some more info.

Which version of the Apalis T30 are you using?

Also, do you have another carrier board to test this with? When did this stop working?

Hello @gustavo.tx

I’ve been using Apalis T30 V1.1A and also V1.1B - both worked without issue. It stopped working about 2 hours before I posted the above message, I thought I was going mad so decided to consult the Ixora schematics…

I do have another Ixora carrier board however it needs its microSD socket replacing as the latch is broken and the card no longer remains in place!

If SD car socket is broken you can use RMA form and get board replaced if it’s still on warranty.

@alex.tx Thanks however I think both of our carrier boards are well past their warranty periods. With this one, I was just wondering if there was an obvious suggestion if this type of issue has been seen previously.

Hi @kwebster83,

Is this issue still happening with you?

If so, let me know and I’ll try to reproduce it at my side with an Apalis T30.

I found it strange to know that it was working fine and then it suddenly stopped working.

Have you tried with different SD Cards?

What I suggest you to try:

  • As the SD Card is not working, can you try to Flash the module through the USB or Network?
  • If you have an Apalis T30 already flashed with WinCE or Linux, can you insert it at your board, insert the SD Card, and check if the device is recognized by the system?

Best regards,
André Curvello