Issue on Silverlight/XAML app with explorer disabled

After disabling the WEC2013 “explorer” desktop via registry, the Sliverlight/Xaml app is able to run but no display showing on the screen. The Silverlight/Xaml app runs fine with “explorer” enabled. Is there an insight on how to make the Silverlight/Xaml function fully without the “explorer” desktop?


Dear @yzoupri

There is a mechanism built into the system which enables the display only after the first GDI graphics operation. Usually this is not an issue, but possibly Silverlight uses OpenGL and thus never triggers the OS to enable the display.

Please try to run any of our graphical tools (e.g. GpioConfig) by using the AutoRun mechanism. Is the tool and/or your Silverlight application visible after this measure? If it works we can create a small application which does some dummy graphics output, which you can start instead of the (unwanted) tool.

Regards, Andy

Hi Andy,

You are correct on the behavior – if I start another graphics program first then my Silverlight program will have the display normally. So could you create a small inconspicuous application as you mentioned.


Dear @yzoupri,

Could you follow the steps documented here : to create a simple console application and run it on the device using Autorun or Init feature.

Thanks, please mark the issue as resolved.