Increase USB Speed on Colibri T20

I am using Colibri T20 and on any module initially USB (B to A) connection to PC won’t work.
I get “USB not recognized” message on the computer unless I go to registry and edit the built-in USB and set High speed to ‘0’ (full speed) rather than high speed.
But then when I connect it back on the computer it connects but I get the message that “Device can work faster” and it is USB 2.
How can I get it connect via USB and have High speed at the same time ?

Hi. maybe it’s an hardware issue : what is the carrier board you use with the Colibri module? For example if you use an old board or a custom board with a design for full speed, high speed will not work.
See here : USB 2.0

Dear @shiva_eghbal,

Are you using Toradex carrier board or own carrier board? If Toradex carrier board, could you please share version and name of the carrier or eval board?

Please make sure your carrier or eval board supports USB High speed.

Related :

I am using our own board and also Colibri Evaluation board V2.1.
From the link you sent me I realised that the evaluation board is not compatible with USB 2.
However I don’t understand why our own board doesn’t work with USB 2.
If I change the registry setting to High Speed = ‘1’ then after reboot/warmboot I won’t have the USB connection and get the “USB not recognized” error.

Do you know why might be the reason that our board is not working with high speed USB ?

The frequency on high speed USB bus is higher than a full speed USB bus : check your hardware design you are probably filtering the high speed frequency (check capacitors values, ESD component datasheet ect…). This is probably why this not working. You can use the design of Toradex Iris carrier board as example.

Dear @shiva_eghbal,

Could you please share detailed information about Colibri Eval board and Your Carrier board schematic differences of USB section? If possible, please share your schematic, we will just look it.

USB Hight speed works on the T20, WinCE6. If you have our other carrier board or eval board, you can confirm on that with setting HighSpeed=1.

KB article about USB 2.0 :