Imxv4l2sink works with textoverlay?

I tried to use textoverlay with imxv4l2sink. When I ran this command on the target board, I got an error.

~# gst-launch-1.0 v4l2src device=/dev/video4 ! video/x-h264,width=1920,
height=1080,framerate=30/1 ! vpudec ! textoverlay text="Room A" valignment=top halignment=left font-desc="Sans, 20" 
! imxv4l2sink sync=false

[INFO]  Product Info: i.MX6Q/D/S
====== IMXV4L2SINK: 4.1.4 build on Oct  4 2017 23:03:28. ======
Setting pipeline to PAUSED ...
display(/dev/fb0) resolution is (1024x768).
[INFO]  Product Info: i.MX6Q/D/S
====== VPUDEC: 4.1.4 build on Oct  4 2017 23:03:36. ======
        wrapper: 1.0.68 (VPUWRAPPER_ARM_LINUX Build on Oct  4 2017 22:43:46)
        vpulib: 5.4.35
        firmware: 3.1.1.46072
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
[INFO]  bitstreamMode 1, chromaInterleave 1, mapType 0, tiled2LinearEnable 0
v4l2sink need allocate 3 buffers.
ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Internal data flow error.
Additional debug info:
../../../../gstreamer-1.8.3/libs/gst/base/gstbasesrc.c(2948): gst_base_src_loop (): /GstPipeline:pipeline0/GstV4l2Sr
c:v4l2src0:
streaming task paused, reason error (-5)
Execution ended after 0:00:02.068169957
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Total showed frames (8), playing for (0:00:02.068712958), fps (3.867).
Freeing pipeline .

Can I use textoverlay with imxv4l2sink?
Thank you.

I am sorry to bother.
If I set composition-meta-enable to true for imxv4l2sink, the it works.
Thank you.

Perfect, that it works. Thanks for the feedback.