Imx6ull package manager

I’ve using a Colibri imx6ull with the linux minimal image. I have problems installing new packages. It seems as apt-get and dpkg is not installed and when I try to install packages with opkg i get:

  • opkg_prepare_url_for_install: Couldn’t find anything to satisfy ‘python3’.
    for any package i try to use. I’ve tried opkg update but that doesn’t help.
    Can anyone help me?
    best regards,

A package managers are not included in a reference images. You can build a custom image with all components recuired for your application. Please check this articles for details:

Okay. I worked with the imx8 before and then docker was installed and I could install everything I needed in a docker container. Is there an image with docker for the imx6ull?

Hi @pontusoim ,

on the currently available versions of the Colibri iMX6ULL we do not support Torizon as you can see on our features list of the 6ULL under OS. Which is what you have been using on the iMX8 I assume.

You can also see there that there’s a version of the Colibri iMX6ULL coming that will support the use of Torizon.

Hope this clears things up :slight_smile:

Best Regards

Okay. So if I want to be able to install any packages on the iMX6ULL i need to build a custom image?
Best regards,

Hi @pontusoim!

Yes, indeed.
As stated here, after BSP 3.0 you cannot install packages from an online feed, only packages you build.

Please, refer to this article on how to do it:

Let me know if you need any help.

Best regards,

So I’ve managed to install apt on my image and it works but it can’t find any packages. The /etc/apt/sources.list file is empty so im guessing it doesn’t know where to get packages from. Also, I get this error:

Skipping acquire of configured file ‘main/binary-${DPKG_ARCH}/Packages’ as repository ‘Index of /raspbian bulls
eye InRelease’ doesn’t support architecture ‘${DPKG_ARCH}’

In this case I tried with the same content sources.list file as my raspberry pi since both run armv7l but it didn’t work.
Also, do I need to define DPKG_ARCH? I tried to do it with dpkg --add-architecture but that didn’t work either.

Does someone know how to build apt on a Colibri imx6ull module and get it working?


Hi @pontusoim,

I’ve answered you here: Apt-get can't find packages on Yocto Build - #2 by hfranco.tx

Let’s continue our discussion there. I will close this ticket since it’s the same as the other one.

Best regards,