IMX6 SPI CS issue

I am having trouble getting the correct spics to work. i am using spi1. When i used the cs pin 227 using the following code it works and i can see on the scope.

fSuccess = Spi_SetConfigInt(ADCSPI, L"ioCS ", IOAPALISPIN(227), StoreVolatile);

However when i change the pin to 116 to use a different CS this does not seem to show on the scope.I have gone into the gpio tool and checked what 116 is set to. I have tried gpio and ecspi1.ecspi1_ss1.

I have tried with library ToradexCeLibraries_2.1b4298-20180207 and toradexcelibraries_v1_9_3609

I have also done the same test with the demo code with the same results.
Any ideas why this will not be working?

I think I had a similar issue recently on a Colibri SOM. Did you try using one of the other SPI ports (SPI2 or SPI3, if available) with 116 as the CS pin?

Can you post a more extensive sample?
This pin should work as CS. We configure it as a GPIO because there is a HW limitation on the controller that will prevent sending large packets without having CS toggling in between.
After your first operation you should see pin 116 configured as a GPIO output.
We are working on a new release of the libraries that will support any GPIO-capable pin as CS, but I can’t give you a release date yet.

I have had the same issue with the demo library program substituting the line with

 fSuccess = Spi_SetConfigInt(ADCSPI, L"ioCS ", IOAPALISPIN(116), StoreVolatile);

It needs to work on this pin as we ordered custom boards last week which uses this chip select and spi channel.

Is there anything i have to do different from the demo program to use that pin?

It seems to be working fine now using the demo code with the new library. the old libraries seem to work sometimes but not others. This is with the same code and board so i am no sure why.

Can you test this version of the libs?
https://share.toradex.com/12zwo8ejkwpuk3v
Please be warned that this is not an official release and shouldn’t be used in production but, of course, if it fixes your problem this fix will be part of the next official release.

It was working on some pins and not others? Or on the same pin?
Anyway it’s good to know that the custom release of the libs fixes the issue. We are going to include those changes in our next image.