I2c device speed with sysfs

imx8mp-verdin-wifi-dev.dts (103.2 KB)

I changed line 1576 from 0x61A80 to 0x9c40.

Thanks for showing me the clk_frequency file, that’s helpful. Maybe I’m setting an impossible frequency?

Have you tried 100KHz frequency?

No but only because I think that’s too fast for my application. This signal needs to run over long wires bundled with my main power to talk to the battery.