i.MX8QM recovery mode no display


I followed the information for entering recovery mode from Toradex website for Apalis i.MX8QM. I.e, I removed the heatsink, connected the device to the host computer, shorted the 2 pins and powered the device on.

We had previously installed boot2qt and the device shows up as a QDB device in the Windows device manager when powered on, but there is no signal to the display.

Also now if I power up without shorting the 2 pins there is no signal to the display.

I have tried switching between a VGA connector and a DVI to HDMI connecter on different displays but they are not working.

Hello DWPM,

so which carrier board are you using ? Are you using a custom carrier board?

Best Regards,


Thanks for getting back to me Matthias.

We are using the Apalis evaluation board.

As an update… There is signal when you power the board up in normal mode (without shorting the pins) and boot2qt goes to the startup screen successfully (using DVI to HDMI connector).

Also, when attempting to enter recovery mode, the red light next to the SoM (RESET MOCI) stays red - does this indicate the system has gone into recovery mode successfully? Or is this a problem?

Although the light stays red, we still do not get output on the screen or see the toradex easy installer.

Thanks for your help


did you connect the debug URAT? Do you see something there?
Also try to hold the SOM in the recovery mode for a bit after turning the power back on befor you release the recovery contact.



I can see the boot output and log into the boot2qt OS via the UART serial connection (X29) when powering the device without recovery mode. An example/snippet of the output read from the serial is below:

U-Boot 2018.03-0+git.548a7dcc2424 (Nov 23 2020 - 10:17:52 +0000)

CPU:   Freescale i.MX8QM revB A53 at 1200 MHz at 49C
DRAM:  4 GiB
Loading Environment from MMC... OK
In:    serial
Out:   serial
Err:   serial
Model: Toradex Apalis iMX8 QuadMax 4GB Wi-Fi / BT IT V1.1B, Serial# 06804985

  - SCFW b929edfe, SECO-FW 27167ff2, IMX-MKIMAGE d7f9440d, ATF bb209a0
  - U-Boot 2018.03-0+git.548a7dcc2424 

switch to partitions #0, OK
mmc0(part 0) is current device
flash target is MMC:0
Net:   eth0: ethernet@5b040000
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot:  1  0 
MMC: no card present
MMC: no card present
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1...
Found U-Boot script /boot.scr
1836 bytes read in 19 ms (93.8 KiB/s)
## Executing script at 86000000
106496 bytes read in 9 ms (11.3 MiB/s)
Loading hdp firmware from 0x0000000084000000 offset 0x0000000000002000
Loading hdp firmware Complete
147549 bytes read in 20 ms (7 MiB/s)
14 bytes read in 17 ms (0 Bytes/s)
23650816 bytes read in 415 ms (54.3 MiB/s)
## Flattened Device Tree blob at 84000000
   Booting using the fdt blob at 0x84000000
   reserving fdt memory region: addr=84000000 size=45000
   Loading Device Tree to 00000000fd62f000, end 00000000fd676fff ... OK
/dma-controller@5a1f0000, 77684
/dma-controller@591F0000, 78640
/dma-controller@591F0000, 78640
/dma-controller@599F0000, 79700

Starting kernel ...


Boot to Qt for Embedded Linux 3.0.4 b2qt-apalis-imx8 ttyLP1

b2qt-apalis-imx8 login:

When I enter recovery mode, the UART serial connects, but does not output any information. Then after a few minutes, the red light switches off again and the Toradex boots like above.

As an extra note, SSH on the X50 connector stopped working which is one reason why we want to install a new OS on the SoM.

Is there some jumper or other setting I have missed? It looks as though it only doesn’t display output to screen in recovery mode?

Hope this makes sense

Thanks again

I’ve now tried this on a second Apalis evaluation board which was running Torizon and the problem appears to be the same, either it is not going into recovery mode or there is no signal to the display.

Hello DWPM,

Wich Toradex Easy Installer(TEZI) version have you downloaded.
It is not clear from you description but are you aware that after you have put the module in the recovery mode you have to run the Toradex easy installer on your host PC.
Make sure that the host PC has recognized the Apalis SOM.
When in recovery mode it should list as either freescale or NXP device. Then you can run the Tezi installer script. make sure you download the right one for your version of the SOM.
Until the host has loaded the TEZI in to the RAM of the module you will see nothing.
Which version of the IMX8QM do you have ?

Best Regards,

Matthias Gohlke

Hi Mattias,

Thanks, I just found the documentation for that and will look into it.

Thanks for your help

Hello DWPM,

ok get back to us if you need more help>

Best Regards,

Matthias Gohlke