How to remove "quiet" from default boot arguments?

I’m working on a device tree customization with Torizoncore and I need to see why the boot is failing, but I think the “quiet” kernel argument limits the output to the console:

U-Boot 2020.04-5.3.0+git.7f3416a28c34 (Jan 01 1970 - 00:00:00 +0000)

CPU:   NXP i.MX8QXP RevC A35 at 1200 MHz at 50C

DRAM:  2 GiB
Loading Environment from MMC... OK
In:    serial
Out:   serial
Err:   serial
Model: Toradex Colibri iMX8 QuadXPlus 2GB IT V1.0D, Serial# 07269706

  - SCFW bc122ee1, SECO-FW 7aeb8423, IMX-MKIMAGE 8947fea3, ATF 835a8f6
  - U-Boot 2020.04-5.3.0+git.7f3416a28c34 

flash target is MMC:0
Net:   eth0: ethernet@5b040000 [PRIME]
Fastboot: Normal
Saving Environment to MMC... Writing to MMC(0)... OK
Normal Boot
Hit any key to stop autoboot:  0 
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1...
Found U-Boot script /boot.scr
1182 bytes read in 11 ms (104.5 KiB/s)
## Executing script at 83200000
5435 bytes read in 24 ms (220.7 KiB/s)
126875 bytes read in 33 ms (3.7 MiB/s)
35 bytes read in 27 ms (1000 Bytes/s)
Applying Overlay: E1171-rev1-imx8x.dtbo
5594 bytes read in 35 ms (155.3 KiB/s)
12191751 bytes read in 296 ms (39.3 MiB/s)
Uncompressed size: 30671360 = 0x1D40200
9170396 bytes read in 226 ms (38.7 MiB/s)
## Flattened Device Tree blob at 83100000
   Booting using the fdt blob at 0x83100000
   Loading Ramdisk to fcdad000, end fd66bddc ... OK
   Loading Device Tree to 00000000fcd6b000, end 00000000fcdacfff ... OK

Starting kernel ...

[    0.138797] No BMan portals available!
[    0.140020] No QMan portals available!
[    1.539496] imx8qxp-lpcg-clk 37620000.clock-controller: failed to get clock parent names
[    2.010748] imx6q-pcie 5f010000.pcie: pcie_ext clock source missing or invalid
[    2.081838] debugfs: Directory '59040000.sai' with parent 'imx8qxp-sgtl5000' already present!
[    2.338358] imx6q-pcie 5f010000.pcie: ERROR PM_REQ_CORE_RST is still set.
[    2.366354] imx6q-pcie 5f010000.pcie: PCIe PLL lock timeout
Starting version 244.5+
[    7.637146] mcp251x spi0.0: MCP251x didn't enter in conf mode after reset
[    7.644077] mcp251x spi0.0: Probe failed, err=16
[   10.511994] Update error: boot checks failed (attempt 2 of 3). Rebooting...
[   19.327514] reboot: Restarting system

How can I disable or remove the default “quiet” argument?

Hi @hordur ,

Welcome back to the community. :wave:

Probably the easiest way to achieve that would be to stop in U-Boot and enter the following:

setenv tdxargs "loglevel=7 earlycon"

If you want to keep it after reboot you can save the environment with:


Hope this helps.

Best Regards

Thanks for the very quick reply, that worked.

(however, the problem was not in the device tree, but some systemd unit that failed to start and caused the update to be mark as failed)

Hi @hordur !

Thanks for the information!

Have a nice day! :slight_smile: