How to get into bootloader menu

I am using this UART connector to connect to the UART1 header on the Ixora evaluation board I am using to start the bootloader menu on my Apalis iMX6 but I have tried everything and nothing seems to actually work. All I get is a garbled mess like the screenshot below.

alt text

Things I have tried:

  • Different UARTs and different connection combinations.
  • Holding down / spamming space bar on each UART connection.
  • Attempting to boot in recovery mode by shorting the connector on the Apalis Module. This doesn’t output anything on UART btw.

So I guess my question is mostly: how to I connect the C232HD cable correctly to the UART headers to achieve a proper TTY? I am fairly sure I have connected it correctly and have tried multiple iterations and combinations.

Edit: on UART2 I get this screenshot.

alt text

No, as Ixora incorporates true RS232 transceivers its UARTs are actually RS232 voltage level and not 3.3 volt TTL! Please hook up to the UART as indicated in the following article on our developer website.