How to flash nand with kobs-ns in colibri-imx7d

hi experts
the borad is colibri-imx7d 512MB V 1.1D
in the field , my mistake i erased l nand-flash while updating u-boot

the board is n’t connect internet, on a PC which the board is connected , no vnc client is stalled

i run TEZI on PC and the board booted well in recovery mode with linux console and mount sd-card which has u-boot.nand.imx

i tried to flash nand but failed

what i did is

  1. /mnt # kobs-ng init -x -v u-boot-nand.imx
    2 nandwrite /dev/mtd2 u-boot-nand.imx
  2. nandwrite /dev/mtd3 u-boot-nand.imx

but it doesn’t boot
u-boot-nand.imx is from JFrog

any hints will be apprecated

Hi @hyoungki , I could not entirely understand if the issue is with the current Toradex Easy Installer image or with the status of the module. In either case, it is good that you are able to run Toradex Easy Installer from recovery mode.

However we don’t recommend running nand flash commands by yourself unless you really know what you are doing. Instead you should always flash the module using Toradex Easy Installer since it is the greatly tested scenario.

Is there any chance you can create your own Toradex Easy Installer with the JFrog U-boot? In most cases, you should be able to do this taking our own images and simply swapping the U-boot, making sure to do the proper changes to image.json. You can always run Toradex Easy Installer through recovery mode if the image doesn’t boot.

Alvaro.

thank you for advice
a PC which a board is connected to didn’t have VNC client , so i just thought to flash on command line
forturnately i found another PC with VNC , so i did flash a board