How to disable LVDS on Apalis TK1

I need to disable the LVDS display on the Apalis TK1. How do I do that?

You may simply disable LVDS from user space using XrandR e.g. as done here. However please note that if no HDMI screen is connected/active LXDM resp. lxpanel may have issues due to no display being available at all. However in case of a head less system LXDM and friends should anyway be disabled.

You may reconfigure the kernel as follows:

# CONFIG_TEGRA_LVDS is not set

make menuconfig
Device Drivers > Graphics support >[ ] Enable LVDS panel.

I solved this by adding the following to /etc/X11/xorg.conf:

Section "Monitor"
    Identifier "LVDS-0"
    Option "Ignore"

This works for me for now.

Thanks for you help.

Yes, I guess that works as well as it is basically using XrandR behind the scenes as well.

Thanks for you help.

You are very welcome.