How to deploy vc++ project to Colbri Board in visual Studio 2013.?

I am not able to run windows form application in visual studio environment for Toradex Board. How should i Proceed ahead.

Using our latest OS images (1.3 stable or 1.4beta2) you should just start the debugger client on the target (start menu, toradex tools, start debugger client), then add the IP address of your device in the “debug” tab of your project options as described here:
https://developer.toradex.com/knowledge-base/application-debugging-over-ethernet-using-visual-studio-2008#Prepare_Visual_Studio_20132015_VS20132015
Then you should be able to deploy and run your application.
If that does not happen, please provide a more detailed description of what happens on your PC and target device, including any error message displayed.

alt text

I am using the latest Os Image and I have given the the ip adderess while deploy.But still i am getting this error.

This is not a C++ application, looks like a .NET application.
Did you install the .NET runtime on the target already?
Did you start the debugger on the target device?
When you start it you should see your device IP address, can you try to ping it?

I tried to ping the embedded device , its working fine.But my IDE goes to freeze while deploying. I think windows mobile device center might be having the problem. I even restarted the MSDC exe.

I think that windows mobile device center is no longer used by VS debugger and a WEC2013 device should not be recognized by it, since ActiveSync is no longer there.
Did you try to configure the IP in the project properties instead of providing it when starting deployment?
Do you have personal firewalls etc. enabled on your PC? Can you try to temporarily disable them?

I already tried disabling the firewall, but project not deploying.

Please provide a more detailed description of what happens on your PC and target device, including any error message displayed.

I am trying to work on c++ console application in msvc2013 . My board is iris rev1.2 and the SBC is imx6 dl with ce08 . I tried to implement the same example as said by toredex “Application development on Windows Embedded Compact 2013”. But when i try to deploy msvc is going to freeze state. or some times it pops up message “Connection refused by target”.

Did you configure IP address in debug settings or you inserted it when prompted by Visual Studio?
Adding address in VS does not work, it’s a known issue that has never been fixed in VS2013.
But you mention C++ and your screenshot shows a C# application, can you pls upload your test code on share.toradex.com and post a link here?

I tried to configure ip in debug setting but couldn’t find in msvc 2013 and the my device icon on target is not coming Ie Mobile. I tried for both c++ and c# but the result was same …I shared the code in this link its simple application “https://share.toradex.com/ybr7bp5130pc5fk

Settings are different compared to VS2008 where you have the connection icon and device selection.
In VS2013/2015 you should configure IP in the “debug” tab of the project configuration dialog, as described here:
https://developer.toradex.com/knowledge-base/application-debugging-over-ethernet-using-visual-studio-2008#Prepare_Visual_Studio_20132015_VS20132015

alt text

I am unable to add the ip address in debug tab. Below i have attached a screen short.Please have a look.

Those are Solution Properties, you should right click on your project (item inside the solution that is the top-level item) and you should have the “debugging” tab there.

Here’s a screenshot alt text

Hi team ,
Thank you for the response . It worked.