How to configure httpd server for browser caching

Hi,

I have ported a WIN CE 6.0 application to WEC2013 which also has a web portal. The web pages on the new port comes very slowly. To give you an example the one which took 1 secs to load now takes 30 to 60 seconds! I found the problem. I seems that the web browser tries to load all the png image files every time they are opened. It is not caching the images.

My question is how do I configure httpd server to enable to cache the images and other redundant files?

Thanks in advance.
Arif

Caching should be the default behaviour unless something different is specified using the
cache-control HTTP header or the tag inside your HTML documents.
I found no specific settings to change this behaviour on the server, but it may be that something has been changed between CE releases.
How do you return your pages? Via ISAPI dlls or using an .ASP scripted page?
Do you change cache-related headers inside your code?
Can you try to use fiddler or a similar tool to examine the exact output of the HTTP request that triggers this issue and of the requests related to png images?
Are you connecting using HTTP or HTTPs?

I haven’t changed any pages or anything on the client side. Yes, returning the pages through ISAPI dlls. I just ported the ISAPI apps to WEC2013 and for VS2013. The ISAPI calls seems working fine. I have used Charles application and found that the HTTP Get for the png, js etc. is causing the delays. I am using HTTP.

Do you have some dumps of the HTTP requests for the images etc.? To understand if caching headers are used in some way.