How to change HDMI resolution to 800x480

Configuration: Apalis IMX6, Boot2Qt image 5.12.4, Screen with 800x480 connected to HDMI port.

How to change HDMI resolution to 800x480 ? I’ve updated boot videoargs to following.

root@b2qt-apalis-imx6:~# cat /proc/cmdline 
vmalloc=400M user_debug=30 ip=off root=/dev/mmcblk1p2 ro rootfstype=ext4 rootwait fec_mac=00:14:2d:a0:97:58 consoleblank=0 no_console_suspend=1 console=tty1 console=ttymxc0,115200n8 mxc_hdmi.only_cea=1 video=mxcfb0:dev=hdmi,800x480M@60,if=RGB24 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M

fbset doesn’t show 800x480. Is that a problem ? The boot2qt image doesn’t come with xrandr command, so I am not able to add 800x480 resolution.

root@b2qt-apalis-imx6:~# fbset

mode "640x480-60"
	# D: 25.176 MHz, H: 31.469 kHz, V: 59.942 Hz
	geometry 640 480 640 960 16
	timings 39721 48 16 33 10 96 2
	accel false
	rgba 5/11,6/5,5/0,0/0
endmode

Hi @qtdevelop1

Have you tried to set the resolution in trough vidargs in u-boot?
https://developer.toradex.com/knowledge-base/display-output-resolution-and-timings-linux

This should work for boot2qt as well.
Basically something like:

setenv vidargs 'mxc_hdmi.only_cea=1 video=mxcfb0:dev=hdmi,800x480@30,if=RGB24 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M'

Regards,
Stefan

Hi

Did you also try without the mxc_hdmi.only_cea parameter as the link Stefan provided suggests?

e.g.

setenv vidargs 'video=mxcfb0:dev=hdmi,800x480@30,if=RGB24 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M'

Hi

What exact display are you connecting?

Can you provide the output to the following:

uname -r
cat /proc/cmdline 
xrandr
dmesg | grep fb
find /sys/ -name edid -exec cat {} \;

Max

Thanks.

I was able to set the vidargs to 800x480 and save it using saveenv command, buit it it still defaults to 640x480 resolution.

fbset shows 640x480, please see below.

root@b2qt-apalis-imx6:~# fbset

mode “640x480-60”
# D: 25.176 MHz, H: 31.469 kHz, V: 59.942 Hz
geometry 640 480 640 960 16
timings 39721 48 16 33 10 96 2
accel false
rgba 5/11,6/5,5/0,0/0
endmode

root@b2qt-apalis-imx6:~#

Yes, I’ve tried the following settings.

fbset still shows 640 480

setenv vidargs ‘video=mxcfb0:dev=hdmi,800x480@30,if=RGB24 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M’

setenv vidargs ‘mxc_hdmi.only_cea=1 video=mxcfb0:dev=hdmi,800x480@30,if=RGB24 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M’

I am using following display from Okaya

https://www.cdiweb.com/datasheets/okaya/RH800480T-7x0BQ-APH.pdf

Please see below and let me know if you need any additional information. Thanks.

root@b2qt-apalis-imx6:~# uname -r
4.9.87-2.8.3+g07d40f6ffcbb


root@b2qt-apalis-imx6:~# cat /proc/cmdline 
vmalloc=400M user_debug=30 ip=off root=/dev/mmcblk0p2 ro rootfstype=ext4 rootwait fec_mac=00:14:2d:a0:97:58 consoleblank=0 no_console_suspend=1 console=tty1 console=ttymxc0,115200n8 mxc_hdmi.only_cea=1 video=mxcfb0:dev=hdmi,800x480@30,if=RGB24 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M


root@b2qt-apalis-imx6:~# xrandr
-sh: xrandr: command not found


root@b2qt-apalis-imx6:~# dmesg | grep fb
[    0.000000] Kernel command line: vmalloc=400M user_debug=30 ip=off root=/dev/mmcblk0p2 ro rootfstype=ext4 rootwait fec_mac=00:14:2d:a0:97:58 consoleblank=0 no_console_suspend=1 console=tty1 console=ttymxc0,115200n8 mxc_hdmi.only_cea=1 video=mxcfb0:dev=hdmi,800x480@30,if=RGB24 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M
[    0.687166] mxc_sdc_fb fb@0: registered mxc display driver hdmi
[    0.691077] mxc_sdc_fb fb@0: 720x480 h_sync,r,l: 62,16,60  v_sync,l,u: 6,9,30 pixclock=27000000 Hz
[    0.716543] mxc_sdc_fb fb@1: mxcfb1 is turned off!
[    0.716630] mxc_sdc_fb fb@2: mxcfb2 is turned off!
[    0.716704] mxc_sdc_fb fb@3: mxcfb3 is turned off!
[    1.614136] mxc_sdc_fb fb@0: 640x480 h_sync,r,l: 96,16,48  v_sync,l,u: 2,10,33 pixclock=25175000 Hz
[    2.093728] mxc_sdc_fb fb@0: 640x480 h_sync,r,l: 96,16,48  v_sync,l,u: 2,10,33 pixclock=25175000 Hz
[    2.306446] mxc_sdc_fb fb@0: 640x480 h_sync,r,l: 96,16,48  v_sync,l,u: 2,10,33 pixclock=25175000 Hz
[    9.073372] mxc_sdc_fb fb@0: 640x480 h_sync,r,l: 96,16,48  v_sync,l,u: 2,10,33 pixclock=25175000 Hz
[   10.188504] mxc_sdc_fb fb@0: 640x480 h_sync,r,l: 96,16,48  v_sync,l,u: 2,10,33 pixclock=25175000 Hz


root@b2qt-apalis-imx6:~# find /sys/ -name edid -exec cat {} \;
0x00 0xFF 0xFF 0xFF 0xFF 0xFF 0xFF 0x00 0x42 0x83 0x01 0x07 0x00 0x00 0x00 0x00 
0x04 0x1B 0x01 0x04 0x90 0x16 0x0E 0x78 0x02 0xF8 0x87 0x96 0x5A 0x55 0x95 0x28 
0x22 0x51 0x55 0x00 0x00 0x00 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x01 
0x01 0x01 0x01 0x01 0x01 0x01 0x70 0x17 0x20 0xEC 0x30 0xE0 0x18 0x10 0x40 0x30 
0x57 0x00 0xD9 0x88 0x00 0x00 0x00 0x1A 0x16 0x12 0x20 0x80 0x30 0xE0 0x16 0x10 
0x30 0x20 0x47 0x00 0xD9 0x88 0x00 0x00 0x00 0x1A 0x00 0x00 0x00 0xFE 0x00 0x43 
0x33 0x47 0x52 0x4E 0x80 0x31 0x30 0x31 0x57 0x58 0x31 0x0A 0x00 0x00 0x00 0x00 
0x00 0x00 0x41 0x32 0xA8 0x00 0x00 0x00 0x00 0x01 0x01 0x0A 0x20 0x20 0x00 0xB3 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
root@b2qt-apalis-imx6:~#

Hi @qtdevelop1

Did you try to connect your display to a PC?
Did you get the correct Image there?
If Yes, could you provide the Edid Information from your PC?

According to the EdidReader, your display is not compatible with the resolution of 800x480.

Best regards,
Jaski

Thank you. Very helpful

I was able to set toradex to output 1280×1024 @ 75 Hz and it worked fine. I think HDMI controller on the board is down converting format to 800x480.

Perfect that it works. Thanks for the feedback.