How do I get the ADV7280 camera board working with Apalis iMX6 Eval Board? [SOLVED]

Hi,

I’m experiencing two video issues with the iMX6 Apalis Eval Board and the ADV7280-based analogue camera adapter.

  1. pink and green lines
  2. start of frame is moving vertically across the screen

To record the attached video, i used the following command:

gst-launch-1.0 imxv4l2videosrc ! imxvpuenc_h264 ! avimux ! filesink location=adv7280_fcbx10.avi

Same issues with this command:

gst-launch-1.0 imxv4l2videosrc ! autovideosink

dmesg shows:

[ 4639.850915] mxc_v4l2_output v4l2_out.35: Bypass IC.
[ 4639.855890] mxc_v4l2_output v4l2_out.35: Bypass IC.
[ 4640.341705] imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_5 = 0x00000001
[ 4640.393361] imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_5 = 0x00000001

Kind regards

Christian

We have the same problem…

Hardware:

  • Apalis iMX6Q 1GB V1.1A
  • Apalis Evaluation Board V1.1A
  • Analogue Camera Adapter V2.0A (ADV7280-based)
  • Analogue Camera Sony FCB-EX2700P
    Software:
  • BSP: Toradex BSP LinuxImageV2.5
  • Image: angstrom-lxde-image

I too have this problem.
See: https://www.toradex.com/community/questions/4049/analogue-camera-module-ver-20a-with-apalis-imx6-gr.html

Please have a look here.
The two questions report likely the same problem. So I’d like to keep comments and answers together in one thread.

[solved] Patching the driver as described in the other post worked for me. Thank you!