How can i reenable the USB Port after CE7 Image 2.0beta Backup&Update?

Hi there,

Thank you for the new Image.

i flashed the Apalis T30 with the new Image CE7 2.0beta. After this i set one device up as i wanted to.
Then i started a “Full Backup” of the Device via Update Tool. I stored the Files on my USB Drive.

Now i did the Same with another board but instead of setup everything i just “updated” using the Backup Files. It seems to work rather good. Splashscreen, Display Settings etc. were working. But one major drewback: The USB Stick is no longer detected by the System (Before it was).

After this i tried it with another T30 … same result.

How can i reenable the USB Port?

Best regards,
Stefan

Hi, can you please contact us via support email Toradex - Customer Support and if possible can you attached your backup. This way we can restore the system and see what happens.

Hi, yes i will send you the Files. I also experienced, that after the “return to factory default” http://developer.toradex.com/knowledge-base/txx-recovery-mode the problem stays.

I hope you can handle ~25MB e-Mails. Please send me a note if you received it.

I did receive it and i also wrote you email back. Please answer as soon as possible

The current NVFlash and old NVFlash version mess up preserving some hardware information like Product ID and mac information in the config block. This leads to the fact that the module things it is a Colibri instead of an Apalis module which leads to a not working USB interface.

We are working on a NVFlash that fixes this issue, it should be released in the next days. Until then, just manually reset the product and mac information like following.

  • Enter the bootloader menu ( http://developer.toradex.com/knowledge-base/bootloader-menu ).

  • Press ‘x’ to get into the command mode.

  • Copy the following commands into a editor and fill in the missing information. After that past it into your terminal tool to restore this information to the module:

         set mac.tidex=0x142D
         set mac.cid=# Type in here the number 
                     # as printed on the label. 
                     # It looks something like 02518272.
         save mac
         
         set hw.vermaj = 1
         set hw.vermin=  #1 if it is a 1.1, 
                         #0 if it is a 1.0 module
         set hw.variant =  #0 if its a "A" module, 
                           #1 if it is a "B" module , ...
         set hw.prodid = #Product ID as shown in the table bellow
         save hw
    
  • Product Ids to be used:

  • 20 Colibri Tegra 2

  • 20 Colibri T20 256MB

  • 24 Colibri T20 256MB IT

  • 21 Colibri T20 512MB

  • 22 Colibri T20 512MB IT

  • 23 Colibri T30 1GB

  • 30 Colibri T30 1GB IT

  • 26 Apalis T30 1GB

  • 31 Apalis T30 1GB IT

  • 25 Apalis T30 2GB

After rebooting USB should work again.