HDMI output TK1

Hello,

I have a Apalis TK1 on an Ixora board.
I followed the instructions for install (can’t recall which version of LXDE I installed though, It was around mid june 2018) Everyhting went fine (I got the message that the install was fine).
Now when I boot, if I connect via UART it seems ok
but when i plug an HDMI monitor, the desktop environment doesn’t seem to start. The OS is not frozen though (it detects if I plug/unplug a keyboard for instance).
Via UART, if I try “xrandr” I get “Can’t open display :0.0”

(I tried 3 different monitors and 2 different cables)
I tried opkg update and upgrade via UART, it works fine but no difference at reboot.

Any input is welcome!
Claire

Please try installing our latest release (2.8b3).
Do you have HDMI output in the Toradex Easy Installer (https://developer.toradex.com/software/toradex-easy-installer)?
If it still fails to work, connect the HDMI cable to the powered off ixora, power it on and capture the uart output of the boot process and post it.

Thanks for your answer.
Can you explain how to do that?
I manage to enter the recovery mode (enterrcm) but I don’t have a PC running Linux to run the script “recovery-linux.sh”…
Do you have a software solution from Windows?

No, only Linux is supported.
You can try with a VM.

Can you help a bit more?
I installed Virtualbox and Ubuntu 14.04, trying to open a connection using gtkterm but nothing appears (I checked with Tera Term on Windows it still works fine).
I’m not sure which port I should use though. dmesg | grep tty returns only tty0 and ls /dev/tty doesn’t return anything in USB …
I see the serial com in the USB devices of the virtualbox but when I click on it I get message “failed to attach” (lsusb doesn’t return it either)

You can leave the USB UART connected to the host system and use teraterm, to use ./recovery-linux.sh you only need to pass “Nvidia APX” USB device to the VM guest linux system.

I managed to communicate with it via the VM finally (using gtkterm and this https://www.groovypost.com/howto/mount-usb-drive-virtualbox/ it appears as /dev/ttyUSB0 )
but when I run ./recovery-linux.sh I get the error “./tegrarcm: could not open USB device
Downloading Toradex Easy Installer failed”

Is there anything else I can try?

Just realising the board wasn’t connected on ethernet, is it necessary at this point?

Make sure that Nvidia USB bevice is passed to the guest system.
Line similar to:
Bus 001 Device 059: ID 0955:7740 NVidia Corp. should be visible after running lsusb command.
More instructions and troubleshooting guide can be found here:

https://developer.toradex.com/software/toradex-easy-installer#apalis-tk1

What I get is this (in the VM)
Bus 001 Device 003: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port

In the troubleshoot there’s “If you are using the Ixora Carrier Board, make sure that X9 is configured in OTG mode (remove JP2).” Do you think it could be that?
(If so please explain how to remove JP2)

Ok, my bad.
After I actually did what’s in the link (plug it on the OTG) it worked…
Thanks!

Thanks for letting us know.