Gstreamer error with console image (x11 removed)

Hi,

i currently try to get gstreamer working with the V2.6 Image. My V2.4 Image worked flawless without X11, but when building a modified console image with the following lines in local.conf:

DISTRO_FEATURES_remove = "x11 wayland"
PACKAGECONFIG_remove_pn-gstreamer1.0-plugins-good = " gdk-pixbuf "

and added packages within oe-core/stuff/meta-toradex/recepies/images/console-trdx-image.bb:

GSTREAMER = " \
    gstreamer1.0-plugins-base \
    gstreamer1.0-plugins-imx \
    gst1.0-fsl-plugin \
"
IMAGE_INSTALL += " \
    angstrom-packagegroup-boot \
    packagegroup-basic \
    udev-extra-rules \
    ${CONMANPKGS} \
    ${ROOTFS_PKGMANAGE_PKGS} \
    timestamp-service \
    packagegroup-base-extended \
    eglinfo-fb \
    tslib-conf \
    tslib-tests \
    tslib-calibrate \
    ${GSTREAMER} \
"

gstreamer hangs with the following output:

root@apalis-imx6:~# gst-launch-1.0 tvsrc ! imxv4l2sink
[  125.844070] ERROR: unrecognized std! ffffff (PAL=ff, NTSC=b000
[  125.849940] ERROR: unrecognized std! ffffff (PAL=ff, NTSC=b000
[INFO]  Product Info: i.MX6Q/D/S
display(/dev/fb0) resolution is (800x600).

(gst-plugin-scanner:660): GLib-GObject-WARNING **: cannot register existing type 'GstImxCompositorPad'

(gst-plugin-scanner:660): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

As you can see i already added the solution mentioned in this thread:
https://www.toradex.com/community/questions/1244/couldnt-make-gsreamer-works-on-core-image-minimal.html

sadly this didn’t make a difference.
Is there something else to take care of?

Thank you very much,

Moritz Wagner

This is probably just the known issue as listed in our release notes:

Known Issues:
- gstreamer freezes when generating its initial database on some modules:
    (gst-plugin-scanner:683): GLib-GObject-WARNING **: cannot register existing type 'GstImxCompositorPad'
    The following gets you around this:
      mv /usr/lib/libgstimxcompositor.so.0.12.0 /usr/lib/libgstimxcompositor.so.0.12.0.orig
      gst-inspect-1.0
      mv /usr/lib/libgstimxcompositor.so.0.12.0.orig /usr/lib/libgstimxcompositor.so.0.12.0
    Alternative one can uninstall libgstimxcompositor0
      opkg remove --force-depends libgstimxcompositor0

You were totally right… I feel ashamed, I’m so sorry for asking.
Problem solved.
Thank you very much!