Flashing u-boot to VF-50 1.0A fails


i’m currently trying to use a VF50 V1.0A Module with embedded linux. But flashing according to the manual fails. The module is working with Windows CE 6.0

For me it looks like the bootloader can’t read the sd card plugged into my orchid board.

Error message from bootloader:

>flashloader colibri_vf/u-boot-nand.imx
Error opening image file. The file must be in the root folder of the first partition of the SD card.

I repeated flashing procedure for an VF50 1.1A Module. With the newer versions module flashing worked.

Has anybody tried to flash u-boot on an VF50 V1.0A Module?

This is actually probably due to the version of Eboot which is currently on the module. The directory structure used on the SD card for our Linux images changed some time in the past which older versions of Eboot are not aware of. It expects the u-boot file to be at the root of the SD card rather than in a colibri-vf directory on the SD card. Try moving the u-boot-nand.imx file from the colibri-vf directory on the SD card to the root of the SD card.

Another solution is to go with the Flashing from Scratch approach.

If you opt for the flashing from scratch approach, note that the V1.0 Vybrid modules (which are unfused) require the Colibri Eval Board and must be manually strapped with resistors.

Thank you for your responses.

Placing the u-boot-nand.imx on the sd card root level leads to the same error message.

I also tried to follow the flashing from scratch, with unfused modules. When I connect the resistors like shown on the manual, and power up the module, nothing comes out of the serial interface. (I used 3.3K resistors)

UnfortunateIy I don’t have an EVA-Board V3.1 available, only a V3.2 EVA-Board and a V2.1C , but I would assume that this procedure is working with an an V3.2 EVA-Board too.

Spending more time on this module isn’t economical any more for me. I gonna keep this board for our Windows CE projects.