FlashDisk File not equal after Backup with Update Tool v6.0.5.3293

Hi,

the updateTool.exe seems to fail restore the a FlashDisk file correctly. I do the following:

  1. Update my Colibri T20 with the new tegra_wince_image_2.0beta1
  2. Customize the image so that the touchdisplay and stuff works fine
  3. Backup and Update the module as described Production Programming for Tegra Modules
  4. After the Backup my Touch does not work. When i try to start the touchdriver.exe file in the FlashDisk/AutoRun Folder I get the following error message: " ‘touchdriver.exe’ is not a valid Windows Ebedded Compact application".
  5. When I manually replace the touchdriver.exe in FlashDisk/AutoRun with the original and restart. All works again.

Can you help me with this error?
I attached the Original and the restored touchdriver file.Link to the zip

Hello @dominikh: Thank you very much for the report. We checked the content of your files you sent us. We will try to reproduce this issue to find the root cause. We will provide you an update on this site when we have a updated version of the tool.

Hi Samuel,

thank you very much. As I futher investigated I realized that if you restore the on a diffrent Module, also the registry is not copying correctly. I attached my backup as a zip file.
I the registry we added our custom display settings under [HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\NVDDI\LCD] but the folder LCD does no exist.

Mabye this helps your investigation.

There is currently a bug in Updatetool v6.0.5.3293 when updating to 2.0 beta 1. There are two issues:

  1. Registry is not restored. This is an issue in image 2.0 beta 1 and will be be fixed with image 2.0beta 2 which will be released the next days.
  2. Files are not backed up correctly. This will be fixed with next Update Tool release 6.0.6 3371. The

@dominikh: We just released UpdateTool 6.0.6, but I am not fully sure, if your file corruption issue is also solved. So we have some more questions here:

  • Can your issue be reproudce every time?
  • Can you provide us the backup of the flashdisk nb0 file, so we can analyse if the issue already happend with the backup or with the restore.

@samuel.tx:

  1. Yes it does. I tried to backup several times and restore to several diffrent T20 Modules.
  2. I uploaded the hole backup already i the previous comment. The text “zip file” is a link to the hole backup as a zip.

I tried to backup/update with the new update tool v6_0_6_3358. Now the registry seems to backup correct. But the filesystem doesn’t. This time the file “FlashDisk/System/UnfdMutiTchDrv.dll” does not copy correctly. Here the link to the newly created Backup file.

@dominikh: Sorry, I have missed the first link.

I tried to restore your files with the Update Tool 6.0.6 and all worked fine (Starting latest Update Tool, selecting the cfg file from you on a USB Stick and running the update). I have started from different Images (staring Update from Image 1.4, from our 2.0beta1 or from your 2.0beta 1). After That I compared the original touchdriver with the restored one and it always matched.

Did you check you not only are using the latest Update Tool but also the the dlls that come along with that package?

Could you try to describe some closer how you start the upgrade process or if there is anything you think that could be different you handling the Updater?

@samuel.tx:
Yes I also copy the lastest dlls that are coming with the update tool.

I use the production programming proccess as describe on your homepage (http://developer.toradex.com/knowledge-base/production-programming-for-tegra-modules), with the production programming template v01_01_3232. Should I do it differently?

I also tried to run the latest update tool, then select the cfg-File and the update. Still the same.
On my targets the files are diffrent. I uploaded both System Folder (io and fail).

I checked again and now was able to reproduce this issue. Restoring your backup actually behaved the same as you describe it. I closely checked the backup file (nb0) and did not found the content of the DLL in there but the file itself is part of the FAT table and points to a section full of FFFFF. So it looks something went wrong with the backup itself.

I also tried to get this situation reproduced but had no success so far (running a unified touch, doing a backup the same time, …). Do you remember the circumstances you created the backup? Was there something running in parallel while doing the backup? Did you use the 6.0.6 (2.0.8) tool for creating the backup?

We have only the “\FlashDisk\AutoRun\touchdriver.exe” running, since that’s needed for the touch to work.

I made the backup with the os image V2.0beta1 and the updatetool v6_0_6_3358.

I also tried the new os image V2.0beta2 and here the backup and restore seems to work. I made a backup an restored it to 2 diffrent modules successfully. I have to test it a little bit more, but it seems to work with the new image. Maybe this helps in finding the error.

@dominikh: We fixed some potential issues, that could have caused the issue with the wrong backup. We have published the latest version of the Update Tool here, where you also find some change log details.

@samuel.tx: I tested it on a target it failed before. Seems to be ok.

Since I have 3 weeks of vacaicanse now. I’ll do more test’s in 4 weeks…